Bug 1862801 - [RFE] VM's pending changes warning should be more informative
Summary: [RFE] VM's pending changes warning should be more informative
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Ido Rosenzwig
QA Contact: Guohua Ouyang
URL:
Whiteboard:
: 1862539 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-02 15:57 UTC by Ido Rosenzwig
Modified: 2020-10-27 16:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Make VM's 'pending changes' alert more informative Reason: It wasn't clear enough Result: Clear and informative message to the user
Clone Of:
Environment:
Last Closed: 2020-10-27 16:22:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6184 0 None closed Bug 1862801: Make VM's 'pending changes' warning more informative 2021-02-04 10:43:56 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:22 UTC

Description Ido Rosenzwig 2020-08-02 15:57:43 UTC
Description of problem:
The VM's pending changes warning is not informative in some cases.
For example, when disks, nics or environment variables have changed, the warning states there are pending changes at that tab but does not specify what had changed.


Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1. create a VM and run it
2. make a change like:
     - add a disk
     - add a nic
     - add a environment variable


Actual results:
The 'pending changes' warning list those tabs without specifying what had changed.

Expected results:
should specify the exact disks/nics/env vars that have changed

Additional info:

Comment 1 Ido Rosenzwig 2020-08-03 08:58:18 UTC
*** Bug 1862539 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-10-27 16:22:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.