Bug 1862885 - The dropdown is closed when choosing different measure for top consumers in Cluster Utilization card
Summary: The dropdown is closed when choosing different measure for top consumers in C...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1855556 1873053
TreeView+ depends on / blocked
 
Reported: 2020-08-03 06:20 UTC by Yadan Pei
Modified: 2020-10-27 16:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:22:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6387 0 None closed Bug 1862885: Stop immediate event propagation in dropdown onClick 2020-12-17 10:55:19 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:22 UTC

Description Yadan Pei 2020-08-03 06:20:01 UTC
Description of problem:
When we click 'By Node' or 'By Pod' to show top consumers, the dropdown is closed and data is not shown

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-02-091622

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user view Cluster Utilization card via Home -> Overview
2. click on any Utilization item, such as CPU to view the breakdown info
3. Click the dropdown to show Top consumers 'By Pod' and 'By Node' 

Actual results:
3. The dropdown is closed after clicking 'By Pod' or 'By Node' so top consumers data is not shown 'By Pod' or 'By Node'

Expected results:
3. When user choose 'By Pod' or 'By Node', we should update Top Consumers accordingly

Additional info:

Comment 2 Rastislav Wagner 2020-08-18 07:26:43 UTC
PF issue, reported https://github.com/patternfly/patternfly-react/issues/4698

Comment 5 Yadan Pei 2020-08-24 05:48:54 UTC
1. cluster admin user view Cluster Utilization card via Home -> Overview
2. click on any Utilization item, such as CPU to view the breakdown info
3. Click the dropdown to show Top consumers 'By Pod' and 'By Node', now the data can be shown without error

Verified on 4.6.0-0.nightly-2020-08-23-185640

Comment 7 errata-xmlrpc 2020-10-27 16:22:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.