Bug 1862888 - [OSP16.1] OVN controllers are down after migration from ML2OVS
Summary: [OSP16.1] OVN controllers are down after migration from ML2OVS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 16.1 (Train on RHEL 8.2)
Assignee: Jakub Libosvar
QA Contact: Roman Safronov
URL:
Whiteboard:
Depends On:
Blocks: 1852389
TreeView+ depends on / blocked
 
Reported: 2020-08-03 06:47 UTC by Roman Safronov
Modified: 2020-08-27 15:20 UTC (History)
9 users (show)

Fixed In Version: python-networking-ovn-7.2.1-0.20200611133439.15f2281.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-27 15:20:02 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1890596 0 None None None 2020-08-06 15:07:19 UTC
OpenStack gerrit 745122 0 None MERGED migration: Restart OVS after setting protocols 2020-08-30 09:53:01 UTC
OpenStack gerrit 745643 0 None MERGED migration: Restart OVS after setting protocols 2020-08-30 09:53:01 UTC
Red Hat Product Errata RHBA-2020:3568 0 None None None 2020-08-27 15:20:25 UTC

Description Roman Safronov 2020-08-03 06:47:11 UTC
Description of problem:

After performing ML2OVS to ML2OVN migration procedure according to the documentation procedure https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1/html-single/networking_with_open_virtual_network/index#migrating-ml2ovs-to-ovn
OVN network agents are down.
Existing VMs are not accessible via network.

(overcloud) [stack@undercloud-0 ~]$ openstack network agent list
+--------------------------------------+------------------------------+---------------------------+-------------------+-------+-------+-------------------------------+
| ID                                   | Agent Type                   | Host                      | Availability Zone | Alive | State | Binary                        |
+--------------------------------------+------------------------------+---------------------------+-------------------+-------+-------+-------------------------------+
| 1a9041f0-6d0f-4cc8-bc6a-a29e9e5e3048 | DHCP agent                   | controller-1.redhat.local | nova              | XXX   | UP    | neutron-dhcp-agent            |
| 270038fc-d919-4f45-90dc-8cffef0a6aeb | Open vSwitch agent           | compute-1.redhat.local    | None              | XXX   | UP    | neutron-openvswitch-agent     |
| 3b8edbd2-4ab0-48a8-9101-488c99d77164 | Metadata agent               | controller-2.redhat.local | None              | XXX   | UP    | neutron-metadata-agent        |
| 56127db5-373d-4389-80b3-bd45173f1376 | Open vSwitch agent           | controller-1.redhat.local | None              | XXX   | UP    | neutron-openvswitch-agent     |
| 59089c9b-bca5-4817-987e-242116198b4c | DHCP agent                   | controller-0.redhat.local | nova              | XXX   | UP    | neutron-dhcp-agent            |
| 683f166f-be40-466c-871e-f16b14e5239c | DHCP agent                   | controller-2.redhat.local | nova              | XXX   | UP    | neutron-dhcp-agent            |
| 6deb2705-1cc5-4236-8872-4103d38ef043 | Open vSwitch agent           | controller-0.redhat.local | None              | XXX   | UP    | neutron-openvswitch-agent     |
| 7e539892-43f1-40a6-a127-66f2701ad72e | L3 agent                     | controller-0.redhat.local | nova              | XXX   | UP    | neutron-l3-agent              |
| 9c80d220-8cb2-4320-80b7-817d001cf0ff | Metadata agent               | controller-0.redhat.local | None              | XXX   | UP    | neutron-metadata-agent        |
| b6268a95-20bb-4304-b816-cdc8af96dba4 | Open vSwitch agent           | controller-2.redhat.local | None              | XXX   | UP    | neutron-openvswitch-agent     |
| b7f5d148-08ab-4ef8-9f40-1e8643e11bcb | L3 agent                     | controller-2.redhat.local | nova              | XXX   | UP    | neutron-l3-agent              |
| c0bade83-e0aa-4c2a-81e2-00e35f815632 | Open vSwitch agent           | compute-0.redhat.local    | None              | XXX   | UP    | neutron-openvswitch-agent     |
| de0d35d9-9057-4d26-9832-7a73b88a1ad1 | Metadata agent               | controller-1.redhat.local | None              | XXX   | UP    | neutron-metadata-agent        |
| ee4b13ac-9505-4f35-ad9c-2521973e2ddb | L3 agent                     | controller-1.redhat.local | nova              | XXX   | UP    | neutron-l3-agent              |
| a1ac09da-e8af-40d4-9ae2-0bce96788d8b | OVN Controller agent         | compute-0.redhat.local    | n/a               | :-)   | UP    | ovn-controller                |
| 1a1bf616-cbe0-4815-9769-9b56ff555e59 | OVN Metadata agent           | compute-0.redhat.local    | n/a               | :-)   | UP    | networking-ovn-metadata-agent |
| 57ec835c-3e2f-462d-8731-5067fe9f1395 | OVN Controller agent         | compute-1.redhat.local    | n/a               | XXX   | UP    | ovn-controller                |
| d840e3f4-28df-4053-8bc7-c24602b45bec | OVN Metadata agent           | compute-1.redhat.local    | n/a               | :-)   | UP    | networking-ovn-metadata-agent |
| d99ceb4a-3dac-410f-a75d-4935a5b7d771 | OVN Controller Gateway agent | controller-1.redhat.local | n/a               | XXX   | UP    | ovn-controller                |
| f6d7edf3-1835-4d8d-a294-17c65b2ad08e | OVN Controller Gateway agent | controller-2.redhat.local | n/a               | XXX   | UP    | ovn-controller                |
| 802e0f4a-d4a1-4414-b3f6-359d225497b6 | OVN Controller Gateway agent | controller-0.redhat.local | n/a               | XXX   | UP    | ovn-controller                |
+--------------------------------------+------------------------------+---------------------------+-------------------+-------+-------+-------------------------------+



Version-Release number of selected component (if applicable):
RHOS-16.1-RHEL-8-20200729.n.0
python3-networking-ovn-7.2.1-0.20200611133437.15f2281.el8ost.noarch
python3-networking-ovn-migration-tool-7.2.1-0.20200611133437.15f2281.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run ML2OVS to ML2OVN migration procedure according to the official documentation procedure https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1/html-single/networking_with_open_virtual_network/index#migrating-ml2ovs-to-ovn
2.
3.

Actual results:
OVN agents are down

Expected results:
OVN agents are up and running

Additional info:

Comment 8 Roman Safronov 2020-08-20 07:49:01 UTC
Verified on RHOS-16.1-RHEL-8-20200813.n.0 with python3-networking-ovn-migration-tool-7.2.1-0.20200611133439.15f2281.el8ost.noarch
Verified that OVN controllers are running after migration to OVN.

Comment 13 errata-xmlrpc 2020-08-27 15:20:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (openstack-neutron bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3568


Note You need to log in before you can comment on or make changes to this bug.