Bug 1862996 - OLM's Dependency Resolution Metric is not allowlisted
Summary: OLM's Dependency Resolution Metric is not allowlisted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Alexander Greene
QA Contact: Tom Buskey
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-03 12:42 UTC by Alexander Greene
Modified: 2020-10-27 16:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:22:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 889 0 None closed Bug 1862996 : Add OLM Dependency Resolution Metric 2020-11-12 05:55:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:23:00 UTC

Description Alexander Greene 2020-08-03 12:42:43 UTC
Description of problem:
OLM recently introduced the `olm_resolution_duration_seconds` metric to track dependency resolution metrics for the new SAT-based dependency resolver. This metric was not allowlisted on the cluster-monitoring-operator. 

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1.Inspect [1] to see the list of allowlisted metrics.

Actual results:
The olm_resolution_duration_seconds metric is not listed.

Expected results:
The olm_resolution_duration_seconds is listed.

Additional info:
[1] https://github.com/openshift/cluster-monitoring-operator/blob/master/manifests/0000_50_cluster_monitoring_operator_04-config.yaml

Comment 2 Alexander Greene 2020-08-06 15:49:03 UTC
The PR [1] has been merged.

Ref:
[1] https://github.com/openshift/cluster-monitoring-operator/pull/889

Comment 5 Tom Buskey 2020-08-10 16:47:48 UTC
oc get configmap -n openshift-monitoring telemetry-config -o yaml matches the yaml in the PR
oc version
Client Version: openshift-clients-4.6.0-202006250705.p0-69-ga695d74ef
Server Version: 4.6.0-0.nightly-2020-08-07-202945
Kubernetes Version: v1.19.0-rc.2+5241b27-dirty

Comment 7 errata-xmlrpc 2020-10-27 16:22:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.