Bug 1863000 - [v2v][UI][VMware to CNV VM import] Deployment of VMware controller v2v-vmware fail if VMware URL contains space at the end
Summary: [v2v][UI][VMware to CNV VM import] Deployment of VMware controller v2v-vmware...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Gilad Lekner
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks: 1893277
TreeView+ depends on / blocked
 
Reported: 2020-08-03 12:57 UTC by Ilanit Stein
Modified: 2020-10-30 16:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1867980 1893277 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:22:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
v2v-vmware deployment fail screenshot (62.12 KB, image/png)
2020-08-03 12:57 UTC, Ilanit Stein
no flags Details
v2v-vmware.log (10.82 KB, text/plain)
2020-08-03 12:58 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6273 0 None closed Bug 1863000: deployment of vmware fails if URL contains space 2020-10-30 11:43:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:58 UTC

Description Ilanit Stein 2020-08-03 12:57:53 UTC
Created attachment 1703292 [details]
v2v-vmware deployment fail screenshot

Description of problem:
In VM import wizard,  deployment of VMware controller v2v-vmware will fail,
if the VMware URL contains a space at the end.

$ oc logs v2v-vmware-6f54d8b584-bxtks
...
panic: parse https://10.1.41.37%20/sdk: invalid URL escape "%20" [recovered]
        panic: parse https://10.1.41.37%20/sdk: invalid URL escape "%20"
...

Version-Release number of selected component (if applicable):
OCP-4.5/CNV-2.4

How reproducible:
100%

Comment 1 Ilanit Stein 2020-08-03 12:58:38 UTC
Created attachment 1703293 [details]
v2v-vmware.log

Comment 2 Filip Krepinsky 2020-08-11 10:23:49 UTC
the validation should be fixed both on frontend and backend. Created a new BZ for the backend part: https://bugzilla.redhat.com/show_bug.cgi?id=1867980

Comment 5 Nandini Chandra 2020-10-08 21:18:12 UTC
Verified in CNV 2.5

Verified that the following error message is displayed when the 'vCenter hostname' contains any space whether it's in the beginning, middle or end.
"Hostname must not contain white spaces"

Comment 7 errata-xmlrpc 2020-10-27 16:22:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.