Bug 1863010 - Scaling down worker machineset on bare metal leaves machines stuck in Deleting state and machineconfigpool in updating state
Summary: Scaling down worker machineset on bare metal leaves machines stuck in Deletin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Doug Hellmann
QA Contact: Lubov
URL:
Whiteboard:
: 1871807 (view as bug list)
Depends On: 1855823
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-03 13:26 UTC by Doug Hellmann
Modified: 2020-09-08 10:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1855823
Environment:
Last Closed: 2020-09-08 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-baremetal pull 93 0 None closed Bug 1863010: ensure delete removes the link between machine and host 2021-02-01 09:06:02 UTC
Red Hat Product Errata RHBA-2020:3510 0 None None None 2020-09-08 10:54:35 UTC

Comment 2 Doug Hellmann 2020-08-04 13:50:53 UTC
Added link to the backport PR.

Comment 4 Doug Hellmann 2020-08-17 18:03:49 UTC
Now that the 4.6 fix has been verified, https://github.com/openshift/cluster-api-provider-baremetal/pull/93  is a candidate to merge for 4.5.

Comment 8 Lubov 2020-08-20 06:44:39 UTC
Verified on 
Client Version: 4.5.6
Server Version: 4.5.0-0.nightly-2020-08-20-011847
Kubernetes Version: v1.18.3+1202f2e

Comment 9 Zane Bitter 2020-08-24 17:50:32 UTC
*** Bug 1871807 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2020-09-08 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.