Bug 186306 - Missing dependencies after install
Summary: Missing dependencies after install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 19:55 UTC by Phillip Sorensen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: f7t2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-02 21:36:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python script to find packages with no depends (1.22 KB, text/plain)
2006-03-22 19:55 UTC, Phillip Sorensen
no flags Details

Description Phillip Sorensen 2006-03-22 19:55:22 UTC
Description of problem:

I have a little python script that I use to find the packages that have no other
packages depending on them.  This allows me to remove unwanted packages and
their dependencies.  Using this this with a number of different installs, I have
found that not all the dependencies are being installed.  

After installing the needed package to resolve the problem, an rpm -e shows that
 the new package is indeed dependent on another package.

Ones I have seem so far:

The default install needed binutils, gettext, and gstreamer-tools to be
installed for all dependencies to be met.

An install with all boxes unchecked (pseudo-minimal) needed ghostscript-fonts.

Another customized install with redhat-lsb selected in the installer needed over
30 packages when I removed and reinstalled with yum


Version-Release number of selected component (if applicable):

Fedora Core 5 released DVD / network install tree


How reproducible:

always, but different packages needed for different installs


Steps to Reproduce:
1. Do an install
2. run 'python depys.py' script I attached
  
Actual results:

script fails until dependencies are met

Expected results:

A list of packages with no packages that depend on them 


Additional info:

Comment 1 Phillip Sorensen 2006-03-22 19:55:23 UTC
Created attachment 126499 [details]
python script to find packages with no depends

Comment 2 Paul Nasrat 2006-03-22 20:19:03 UTC
There is already a script in yum-utils to do this:

package-cleanup --leaves you might want to check that out.

It is probable that the deps are deliberately cut due to whiteout.

Comment 3 Phillip Sorensen 2006-03-22 21:34:55 UTC
I tried package-cleanup --problems on a fresh default install.  It came up with
the same results as my script (binutils, openjade, gstreamer-tools).

Comment 4 Chris Lumens 2007-02-27 19:45:46 UTC
What's the status of this in F7?  Lots of stuff has changed on the anaconda side
of things, comps, and package deps themselves.

Comment 5 Phillip Sorensen 2007-03-02 21:11:25 UTC
I just did a default install of Fedora 7 test 2. Both my script and the
package-cleanup utility ran without error.  The bug appears to be fixed. 


Note You need to log in before you can comment on or make changes to this bug.