Bug 1863075 - oVirt CSI driver does not run on master nodes
Summary: oVirt CSI driver does not run on master nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jan Safranek
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-03 15:03 UTC by Jan Safranek
Modified: 2020-10-27 16:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:22:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovirt-csi-driver-operator pull 18 0 None closed Bug 1863075: Allow the driver to run on any nodes 2021-01-12 00:10:39 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:58 UTC

Description Jan Safranek 2020-08-03 15:03:25 UTC
Description of problem:

Steps to Reproduce:
1. Install a cluster on RHEV (and get oVirt CSI driver as part of it)

2. Check CSI driver pods:
   oc -n openshift-cluster-csi-drivers get pod -o wide

3. Create a pod on a master that uses PVC.

Actual results:

2. CSI driver pods run only on worker nodes (using AWS pods as example)
...
aws-ebs-csi-driver-node-4sjs2                   3/3     Running   0          67m   10.0.141.12    ip-10-0-141-12.ec2.internal    <none>           <none>
aws-ebs-csi-driver-node-9zvn7                   3/3     Running   0          67m   10.0.162.142   ip-10-0-162-142.ec2.internal   <none>           <none>
aws-ebs-csi-driver-node-jzzgs                   3/3     Running   0          67m   10.0.194.182   ip-10-0-194-182.ec2.internal   <none>           <none>
...

3. Masters can't use a PVC provided by the CSI driver

Expected results:
2. Even masters have ovirt node  pods
3. Masters can use a PVC provided by the CSI driver

Comment 4 Qin Ping 2020-08-26 03:09:54 UTC
Verified with: 4.6.0-0.nightly-2020-08-26-010422

Comment 6 errata-xmlrpc 2020-10-27 16:22:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.