This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 18631 - ATAPI cd-roms bitch on console when you query w/o cd in drive
Summary: ATAPI cd-roms bitch on console when you query w/o cd in drive
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-08 08:06 UTC by Joseph Malicki
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 02:18:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Malicki 2000-10-08 08:06:15 UTC
Every time i go to a console, but am running autorun in GNOME, and don't 
have CD-ROMs in my drives, I get messages like:

ATAPI device hde:
  Error: Not ready (Sense key=0x02)
  (reserved error code) -- (asc=0x3a, ascq=0x01)
  The failed "Read Cd/Dvd Capacity" packet command was:
  "25 00 00 00 00 00 00 00 00 00 00 00"

I know these are harmless..... but they're EXTREMELY fucking annoying 
considering I get one like every two seconds.  Not to mention a waste of 
kernelspace time.  I know this is like wishlist-type stuff, but can't the 
kernel detect that there's not a cd in the drive and not create this error?

This also makes syslogs almost completely unusable without grepping out 
every line of the error message (which, for some reason, happens to be 
substantially different on each of my CDROM drives).

Comment 1 Thilo Mezger 2000-10-10 08:56:33 UTC
I'm glad you mention this problem here because my CD writer produces the same
error messages making it impossible to toast CDs with cdrecord(1) which worked
fine on a 6.2 machine with kernel upgraded to 2.2.17.

I've got a very old Mitsumi 2x-speed writer connected to IDE and I thought it
was broken now but it's probably one of the 150 additional patches to the kernel
which breaks things... ;-)


Comment 2 Joseph Malicki 2000-10-10 11:45:09 UTC
You should be able to fix that problem by disabling autorun for that drive?

Comment 3 Mark Baseggio 2000-10-12 21:31:24 UTC
same problem!!  fix this shit please!!

Comment 4 K2 2000-11-25 08:00:27 UTC
Same problem with PlexWriter 12/10/32

Comment 5 Arjan van de Ven 2001-01-15 14:39:35 UTC
This is a bug in your cdromdrive the kernel logs. 2.2.19pre and later should not
log it excessively,
but removing autorun / magicdev is also a good workaround.


Note You need to log in before you can comment on or make changes to this bug.