Bug 186311 - xplanet fails to generate an image
xplanet fails to generate an image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xplanet (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Juha Ylitalo
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-03-22 15:38 EST by Joe Christy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 12:33:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3 different invocations, with extracts from STDERR, of xplanet (1.73 KB, text/plain)
2006-03-22 15:38 EST, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2006-03-22 15:38:19 EST
Description of problem:
xplanet, invoked in a variety of ways always fails
Version-Release number of selected component (if applicable):
xplanet-1.0.1-7

How reproducible:
Always

Steps to Reproduce:
1. Invoke, e.g., /usr/X11R6/bin/xplanet
2. Wait ad infinitum
3.
  
Actual results:
Nothing except some warnings and errors on STDERR

Expected results:
A window pops up, or the background fills, with a pretty picture

Additional info:
Cf. attached log fragments
Comment 1 Joe Christy 2006-03-22 15:38:20 EST
Created attachment 126507 [details]
3 different invocations, with extracts from STDERR, of xplanet
Comment 2 Joe Christy 2006-03-23 11:10:52 EST
Hmmm, I built xplanet-1.2.0 from source, installed it and saw the same problems.

So, I went through all the files that my .xplanet/config.default mentions and
regenerated/replaced them. Problems solved.

Now xplanet-1.2.0 built and installed totally without difficulty, so why not
update the rpm to 1.2.0?
Comment 3 Mamoru TASAKA 2006-09-19 03:07:00 EDT
I think we must follow the process of:
http://fedoraproject.org/wiki/Extras/Policy/AWOL_Maintainers
http://fedoraproject.org/wiki/Extras/OrphanedPackages

Well, I am interested in xplanet and currently I use xplanet built by
myself.

Juha, will you have any plan to upgrade xplanet to 1.2.0? At least 
current Fedora xplanet cannot be built in mock, so fixing it is necessary.
This package will get orphaned by FC6 release, which I am very disappointed at.

So, if you will not maintain xplanet anymore on Fedora Extras, I would
like to take over xplanet.
Comment 4 Juha Ylitalo 2006-09-19 03:22:29 EDT
I think it might be good idea for Mamoru or someone else to takeover on this
package, since among other stuff I am planning to skip every second FC release
(from FC5 to FC7 and so on).
Comment 5 Mamoru TASAKA 2006-09-19 03:29:13 EDT
(In reply to comment #4)
> I think it might be good idea for Mamoru or someone else to takeover on this
> package, since among other stuff I am planning to skip every second FC release
> (from FC5 to FC7 and so on).

Thank you for applying. If you agree, I will want to maintain xplanet,
if it okay?
Note: we don't have to maintain FC4 and below FC4, they are already sent to
legacy.
Comment 6 Mamoru TASAKA 2006-09-19 10:55:42 EDT
Well, I would like to upgrade FE5-6 xplanet to 1.2.0 before xplanet gets
orphaned. Would you mind if I do so?
Comment 7 Juha Ylitalo 2006-09-19 11:14:19 EDT
I don't mind, if you want to adopt package and upgrade it for FC6.
Comment 8 Mamoru TASAKA 2006-09-19 11:40:07 EDT
(In reply to comment #7)
> I don't mind, if you want to adopt package and upgrade it for FC6.

Thank you, Then I will try for now.
Comment 9 Mamoru TASAKA 2006-09-19 11:59:44 EDT
Okay.
* I added myself to xplanet co-maintainer.
* I upgraded xplanet to 1.2.0 for FE6-devel and FE-5, and 
  the upgraded version will appear by tomorrow.
Comment 10 Mamoru TASAKA 2006-09-21 11:44:44 EDT
So, xplanet-1.2.0-1.fc5 is released, and is this bug solved?
Comment 11 Joe Christy 2006-09-28 12:19:55 EDT
(In reply to comment #10)
> So, xplanet-1.2.0-1.fc5 is released, and is this bug solved?

Yes, xplanet-1.2.0-2.fc5 works fine. Thanks for taking this over.
Comment 12 Mamoru TASAKA 2006-09-28 12:33:46 EDT
(In reply to comment #11)
> Yes, xplanet-1.2.0-2.fc5 works fine. Thanks for taking this over.

Okay. Thank you for reporting.

Note You need to log in before you can comment on or make changes to this bug.