Bug 186319 - lyx doesn't display graphics
lyx doesn't display graphics
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 16:31 EST by Yusuf Ma
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 13:19:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yusuf Ma 2006-03-22 16:31:28 EST
Description of problem:
lyx doesn't display the inserted graphics. I am using qt frontend.

Version-Release number of selected component (if applicable):
lyx-1.4.0-4.fc5
lyx-qt-1.4.0-4.fc5

How reproducible:
Everytime

Steps to Reproduce:
1. Start a new file in lyx
2. Insert an eps file using the menu "Insert -> Graphics..."
3.
  
Actual results:
 lyx displays "Error converting to loadable format"

Expected results:
lyx displays the inserted graphics in the window

Additional info:
dvi, ps, and pdf files are exported successfully. It seems just a display problem.
Comment 1 Rex Dieter 2006-03-28 10:11:28 EST
You may have an old config in your home directory.  Try
remove/rename ~/.lyx
and/or
From lyx' menu:
Tools->Reconfigure

BTW, what kind of graphic are you inserting?
Comment 2 Rex Dieter 2006-03-28 10:32:05 EST
See upstream report regarding graphic preview probs:
http://bugzilla.lyx.org/show_bug.cgi?id=2376

BTW, to you have the ImageMagick rpm installed?
Comment 3 Yusuf Ma 2006-03-28 19:59:08 EST
I removed
~/.lyx
and did
Tools->Reconfigure
It seems that the problem was solved. It is weird because I installed FC5 on a
freshly formatted hard drive and there should be no old config file in my home
directory. Anyway, I'm happy with the result. Thank you for your suggestion.
FYI, I am using eps graphics and I do have ImageMagick rpm installed.
Comment 4 Rex Dieter 2006-03-29 09:14:28 EST
Glad it worked for you.  

Now, I have to figure out why the Reconfigure was required in the first place
(it shouldn't be)
Comment 5 Yusuf Ma 2006-03-29 15:57:26 EST
To reproduce the problem, I removed the lyx and lyx-qt package and the old
config file, then installed them again. This time, everything worked.

I checked my yum.log. Although I did install ImageMagick, I installed it as a
dependency of xfig after I reported the bug. I think you are right. It is the
ImageMagick  problem. Perhaps the ImageMagick rpm should be added to lyx's
dependencies list such that people don't need to install  ImageMagick separately
after installing lyx to solve the display problem.
Comment 6 Rex Dieter 2006-03-30 13:19:22 EST
Thanks, that helped a lot, so I think we tracked down the cause, to be fixed in
the next pkg iteration:

%changelog 
* Thu Mar 30 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0-5
- %%trigger ImageMagick (#186319)


Note You need to log in before you can comment on or make changes to this bug.