Bug 186334 - (Video) DVDs appear as empty and cannot be mounted
(Video) DVDs appear as empty and cannot be mounted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-03-22 18:13 EST by Hordur Freyr Yngvason
Modified: 2013-03-05 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 19:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
syslog entries from hal after dvd has been inserted (5.64 KB, text/plain)
2007-03-04 10:36 EST, Christian Nolte
no flags Details
lshal output of the device and recognized volume (4.85 KB, text/plain)
2007-03-04 10:37 EST, Christian Nolte
no flags Details

  None (edit)
Description Hordur Freyr Yngvason 2006-03-22 18:13:06 EST
Description of problem:
Basically when I insert a video dvd it is mounted as blank/empty and since it is
FC5 the drive has no fstab entry by default and I'm unable to mount the DVD
easily using terminal and browse to the actual /media/cdrom directory with
nautilus. I've been told this is a hal bug.

Version-Release number of selected component (if applicable):
hal-0.5.7-3 but has been around at least since FC4. Also happens in ubuntu, see
https://launchpad.net/distros/ubuntu/+source/hal/+bug/33242

How reproducible:
Insert a dvd into the drive and it will mount incorrectly. For example Spiderman
(PAL) and the ut2004 dvd. However, some DVDs mount properly (for example linux
distro install DVDs) which has led me to believe that this has possibly
something to do with whether it is DVD+, DVD-, dual-layer etc.

Steps to Reproduce:
1. Insert (video) DVD
2. Try to view the contents of the DVD
  
Actual results:
It won't work unless an audio cd has been in the drive previously that
particular session. Neither will a folder appear in /mount/ (on FC5 that is)

Expected results:
The DVD should play just fine and a folder whith its title should appear in
/mount/. 

Additional info:
If a music cd is inserted into the drive before the dvd, the dvd will play just
fine (but only for that particular session, I think). Very strange.
Also, when I tried using suse 10, this bug didn't occur.
I have a Plextor DVDR PX-712A. When searching for solutions to this bug I found
out that this seems to happen mostly with Plextor DVD drives.
Comment 1 Christian Nolte 2007-03-04 10:35:13 EST
I have the same problem (and the same player: Plextor DVDR PX-712A) using FC6
and hal-0.5.8.1-6.fc6. The problem only occurs with Video-DVD for which the
kernel complains that 'This disc doesn't have any tracks I recognize!' and hal
recognizes as volume_empty_dvd_rom.

I have also filed a BUG report on freedesktop.org:
https://bugs.freedesktop.org/show_bug.cgi?id=8713

A similar problem is discussed in Novell's bugzilla:
https://bugzilla.novell.com/show_bug.cgi?id=222561

Some debug output for a DVD I have problems with:

/lib/udev/vol_id /dev/hdb:
ID_FS_USAGE=filesystem
ID_FS_TYPE=udf
ID_FS_VERSION=
ID_FS_UUID=
ID_FS_LABEL=SCRUBSPAL_S4D3 
ID_FS_LABEL_SAFE=SCRUBSPAL_S4D3
Comment 2 Christian Nolte 2007-03-04 10:36:27 EST
Created attachment 149209 [details]
syslog entries from hal after dvd has been inserted
Comment 3 Christian Nolte 2007-03-04 10:37:08 EST
Created attachment 149210 [details]
lshal output of the device and recognized volume
Comment 4 David Zeuthen 2007-03-04 11:46:01 EST
I think the core of the problem is that the CDROM_DISC_STATUS ioctl returns
CDS_NO_INFO... and since HAL is the gullible type it sets volume.disc.is_blank
TRUE and proceeds not to probe the file system. And this is what I see in
comment 3....

The only fix I have in mind is either

 a) fixing the CDROM_DISC_STATUS ioctl in the kernel
 b) bypassing the kernel and speaking directly to the drive
 c) probe the file system anyway

We already do b) for a number of other things and I'm almost sure that a) is
going to take months or years... c) sounds like a non-starter since we shouldn't
be accessing blank discs. It might be a fix though.

FWIW, I see this issue too on my Sandisk U3 Cruzer Micro in bug 208521 so I
should be able to fix it.
Comment 5 David Zeuthen 2007-03-04 11:53:53 EST
Moving to devel and making this a blocker.
Comment 6 David Zeuthen 2007-03-04 20:54:59 EST
If someone can try this patch

http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=0c16761e61064979daa7b39ce0083f064676e578;hp=f1f5d0e4389c0d2c8b86eb21d0d4681ad3cb739a

and report back it would be appreciated. FWIW it works for by test device. It'll
probably hit Rawhide in a few days regardless. Thanks.
Comment 7 David Zeuthen 2007-03-05 09:56:27 EST
This is now in Rawhide - please verify that it works. Thanks.
Comment 8 Christian Nolte 2007-03-07 14:54:04 EST
The patch fixes the problem for me. 

Note: As I had trouble getting the rawhide package to work on FC6 (selinux
issues and a org.freedesktop.Hal.PermissionDenied when mounting the volume; I
have no access to a rawhide-system), I patched hal-0.5.8-6-fc6.
Comment 9 David Zeuthen 2007-04-02 19:26:18 EDT
Closing as the new package was reported to fix the problem.

Note You need to log in before you can comment on or make changes to this bug.