Bug 186346 - Video and ACPI suspend problems on Compaq Presario X1050
Video and ACPI suspend problems on Compaq Presario X1050
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 21:21 EST by Robert Hancock
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.17-1.2145_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 20:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from suspend/resume with ACPI errors (29.82 KB, text/plain)
2006-03-22 21:21 EST, Robert Hancock
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 6075 None None None Never

  None (edit)
Description Robert Hancock 2006-03-22 21:21:25 EST
Created attachment 126523 [details]
dmesg output from suspend/resume with ACPI errors
Comment 1 Robert Hancock 2006-03-22 21:21:25 EST
Description of problem:

Several suspend problems on a Compaq Presario X1050 laptop on FC5.

Version-Release number of selected component (if applicable):

kernel-2.6.15-1.2054_FC5

How reproducible:

Every time

Steps to Reproduce:
1. Suspend the laptop
2. Resume the laptop
3.
  
Actual results:

Screen goes all white and streaky
After fixing the above (see below) system still doesn't work properly until reboot.

Expected results:

System suspends and resumes normally.

Additional info:

The video state was not restored properly until I added:

        /usr/sbin/vbetool vbestate save > /var/run/vbestate

to the suspend_video and

        /usr/sbin/vbetool vbestate restore < /var/run/vbestate

to the resume_video in /etc/pm/functions-ati. (This system has an ATI Radeon
9000 video chipset.) It seems this is only done on NVIDIA cards but obviously
this one needs it as well.

After fixing that problem, there is still a problem with ACPI on the resume:

ACPI: read EC, IB not empty
ACPI Exception (evregion-0409): AE_TIME, Returned by Handler for
[EmbeddedControl] [20060127]
ACPI Error (psparse-0517): Method parse/execution failed
[\_SB_.C046.C059.C0EA.C132] (Node c14d01e0), AE_TIME
ACPI Error (psparse-0517): Method parse/execution failed [\_SB_.C132] (Node
dfe02e20), AE_TIME
ACPI Error (psparse-0517): Method parse/execution failed [\_SB_.C11F._BST] (Node
dfe02d60), AE_TIME

After this the keyboard acts funny, the battery status is not reported properly
and trying to re-suspend or shutdown often locks up.

The above ACPI issue is also on the kernel Bugzilla (referenced below).

dmesg output is attached.
Comment 2 Robert Hancock 2006-05-23 01:02:48 EDT
The ACPI and keyboard problems appear to have somehow been caused by the
ohci1394 driver not saving/restoring its PCI configuration space on suspend and
resume. A patch for this,
fix-broken-suspend-resume-in-ohci1394-was-acpi-suspend.patch has now been added
to the -mm tree.
Comment 3 Robert Hancock 2006-07-14 20:40:50 EDT
This has been fixed in the latest 2.6.17 update kernels (fix was in upstream
2.6.17.2).

Note You need to log in before you can comment on or make changes to this bug.