Bug 186356 - dbus error on startup
dbus error on startup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 23:59 EST by Braden McDaniel
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 13:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2006-03-22 23:59:13 EST
Description of problem:
When I attempt to start Epiphany while I'm logged in to X as any user other than
root, it fails with a message like this:

** (epiphany:29937): WARNING **: Unable to connect to session bus: Failed to
connect to socket /tmp/dbus-h85d0C0Ubf: Connection refused


Version-Release number of selected component (if applicable):
1.9.8-1

How reproducible:
Consistently

Steps to Reproduce:
1. Log in to X as some user other than root.
2. Attempt to start Epiphany.
  
Actual results:


Expected results:


Additional info:
I upgraded this system from Fedora Core 4 to Fedora Core 5.
Comment 1 Jochen Laser 2006-03-26 02:56:13 EST
This seems to be a general dbus Problem rather than an epiphany Problem.
The bug reproduces on my i386 FC5-installation that was upgraded from FC4.

Starting epiphany from within dbus-launch produces the same error:

dbus-launch  epiphany

** (epiphany:7443): WARNING **: Unable to connect to session bus: Failed
to connect to socket /tmp/dbus-gdyPrhrvbJ: Connection refused


And the same thing (unable to connect to socket...) happens when starting 

 dbus-monitor --session  



Comment 2 Braden McDaniel 2006-04-03 15:46:03 EDT
Another user e-mailed me to say that he had observed the same problem and it was
resolved by installing the dbus-x11 package.

At this point I have already done a clean install of FC5, so I'm not in a
position to confirm whether this would have worked for me.

If this is in fact the problem, there is presumably some package that ought to
be depending on dbus-x11 but isn't.
Comment 3 Steevithak 2006-04-04 09:03:16 EDT
Not sure if this is related but about 50% of the time when my Dell Inspiron 8600
is starting up, dbus dies at a random point after the login screen but before
the desktop is fully rendered. If I boot in a non-X mode and don't use X then
things seem perfectly stable.
Comment 4 major 2006-06-06 22:20:23 EDT
The discussion of Bug 189302 might resolve this problem.
Comment 5 Matěj Cepl 2007-07-18 13:32:32 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 6 Braden McDaniel 2007-07-18 13:52:01 EDT
This was some issue with the upgrade process from 4 to 5. I have not seen it
elsewhere.
Comment 7 Steevithak 2007-07-18 14:57:56 EDT
My Dell Inspiron dbus problem (if it was even related to this bug) vanished when
I updated to Fedora 7.

Note You need to log in before you can comment on or make changes to this bug.