Bug 186358 - gnome-mount ignores mount options from hal policy file
gnome-mount ignores mount options from hal policy file
Status: CLOSED DUPLICATE of bug 188224
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 00:13 EST by Eric Bourque
Modified: 2013-03-13 00:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 13:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Bourque 2006-03-23 00:13:27 EST
I have an external hard disk which has an nfts partition on it. I wrote an fdi
file which worked under FC4, but which no longer works under FC5. The problem is
that the uid and gid mount options from the file are ignored when the actual
mount takes place. I believe it's gnome-mount which is responsible for this, but
please re-assign to the correct component if I'm wrong.

Version-Release number of selected component (if applicable):

gnome-mount-0.4-5

Here is the policy file I added to the third party directory:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="volume.fstype" string="ntfs">
      <append key="volume.mount.valid_options" type="strlist">uid=</append>
      <append key="volume.mount.valid_options" type="strlist">gid=</append>
      <merge key="volume.policy.mount_option.uid=1278" type="bool">true</merge>
      <merge key="volume.policy.mount_option.gid=900" type="bool">true</merge>
    </match>
  </device>
</deviceinfo>

The hal-device-manager shows theys keys correctly, but when the disk is
connected, these options are used:

/dev/sda2 /media/FW_Disk ext3 rw,noexec,nosuid,nodev 0 0
Comment 1 George Billios 2006-03-29 16:13:59 EST
This is very irritating mostly for people outside the ASCII world who have to
mount filesystems with some other charset options that used to work with fstab-sync.

It is two (2) months now that this matter was raised in the fedora-devel list
but nothing happend. As I see it, gnome-mount is a hack, an ugly hack to
introduce into a stable release with no development going on. 

Do you at least have predicted fix date? 
Comment 2 George Billios 2006-05-07 12:05:54 EDT
Bump!

Almost 2 more months have passed!
Comment 3 John (J5) Palmieri 2006-05-08 13:06:46 EDT

*** This bug has been marked as a duplicate of 188224 ***
Comment 4 Luis A. Florit 2006-07-07 22:41:25 EDT
Such an OLD and HUGE bug without any solution!!
Like many others... So: Is Fedora Core DYING???
Luis

Note You need to log in before you can comment on or make changes to this bug.