Bug 1863737 - gnutls: FTBFS in Fedora rawhide/f33
Summary: gnutls: FTBFS in Fedora rawhide/f33
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnutls
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Red Hat Crypto Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-08-03 17:16 UTC by Fedora Release Engineering
Modified: 2020-09-25 16:46 UTC (History)
7 users (show)

Fixed In Version: gnutls-3.6.15-1.fc32 gnutls-3.6.15-1.fc31 gnutls-3.6.15-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-07 17:14:17 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2020-08-03 17:16 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2020-08-03 17:16 UTC, Fedora Release Engineering
no flags Details
state.log (963 bytes, text/plain)
2020-08-03 17:16 UTC, Fedora Release Engineering
no flags Details


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 95450 P3 NEW [10/11 regression] Wrong long double folding 2020-08-17 20:46:53 UTC
Red Hat Bugzilla 1864107 unspecified CLOSED m4: FTBFS in Fedora rawhide/f33 2020-10-14 00:28:05 UTC

Description Fedora Release Engineering 2020-08-03 17:16:29 UTC
gnutls failed to build from source in Fedora rawhide/f33

https://koji.fedoraproject.org/koji/taskinfo?taskID=47965501


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
Please fix gnutls at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
gnutls will be orphaned. Before branching of Fedora 34,
gnutls will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-08-03 17:16:32 UTC
Created attachment 1704729 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2020-08-03 17:16:33 UTC
Created attachment 1704730 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-08-03 17:16:34 UTC
Created attachment 1704731 [details]
state.log

Comment 4 Jeff Law 2020-08-06 00:09:38 UTC
I'm pretty sure the PPC gnulib failures are caused by bogus autoconf tests that are compromised by LTO.  I'll take this BZ.

Comment 5 Ben Cotton 2020-08-11 14:06:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 6 Jeff Law 2020-08-18 04:16:55 UTC
I've disabled LTO on ppc64le.  However there are still armv7hl testsuite failures that are not related to LTO.  So handing this back to the default assignee for further investigation.

Comment 7 Fedora Update System 2020-09-04 12:24:06 UTC
FEDORA-2020-30cd8d9ad6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-30cd8d9ad6

Comment 8 Fedora Update System 2020-09-04 12:24:07 UTC
FEDORA-2020-4246288e21 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4246288e21

Comment 9 Fedora Update System 2020-09-04 12:24:09 UTC
FEDORA-2020-d12739ca45 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d12739ca45

Comment 10 Fedora Update System 2020-09-04 15:13:12 UTC
FEDORA-2020-30cd8d9ad6 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-30cd8d9ad6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-30cd8d9ad6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-09-04 15:28:48 UTC
FEDORA-2020-4246288e21 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4246288e21`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4246288e21

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-09-04 19:17:25 UTC
FEDORA-2020-d12739ca45 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d12739ca45`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d12739ca45

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-09-07 17:14:17 UTC
FEDORA-2020-4246288e21 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-09-19 22:44:37 UTC
FEDORA-2020-30cd8d9ad6 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-09-25 16:46:18 UTC
FEDORA-2020-d12739ca45 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.