Bug 186385 - Install hangs while reading package metadata
Install hangs while reading package metadata
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 05:07 EST by Ralf Kleineisel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 10:16:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Kleineisel 2006-03-23 05:07:04 EST
Description of problem:
When trying to upgrade install from FC5test2 to FC5 from DVD the installer
aborts with the error message:
"Unable to read package meta data. This may be due to a missing rpodata
directory. Please ensure that your install tree has been correctly generated.
failure: repodata/repoxmd.xml from anaconda: [Errno 256] No more mirrors to try."

The DVD check was successful. I tried two different DVDs with the same result.

On virtual console 4 I get the error:
"end_request: I/O error, dev hdc, sector 6354220
Buffer I/O error n device hdc, logical block 1588555"

Version-Release number of selected component (if applicable):
FC6 install DVD

How reproducible:
Always

Steps to Reproduce:
1. Boot from install DVD
2. Choose upgrade
3.
  
Actual results:
Hang, error see above.

Expected results:
Should install.

Additional info:
Comment 1 David Cantrell 2006-03-23 10:16:42 EST
I'm pretty sure we don't support upgrades from test releases to the final
release, only from the last major release to the new one (e.g., FC4 to FC5).

That said, it sounds like either your burner or reader is at fault here.  This
will sound strange, but try burning the disc at a slower speed.  The media check
may pass, but try burning it at a slower speed anyway.  Try another burner if
you can.  Try different media.  Lots of variables, but based on what you said
above, it definitely sounds hardware related.  Burners and readers are very picky.
Comment 2 Ralf Kleineisel 2006-03-23 12:06:38 EST
I compared the install DVD with the content of the image I used to burn it
(mounted the image via loopback and recursively compared every file's md5sum).
They are identical. I used the DVD drive I tried to install from for this test.
The ISO image's sha1sum is correct. 

Note You need to log in before you can comment on or make changes to this bug.