Bug 186399 - rpmlint tracebacks on SRPMS
rpmlint tracebacks on SRPMS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 06:58 EST by Sarantis Paskalis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 03:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sarantis Paskalis 2006-03-23 06:58:33 EST
Description of problem:
rpmlint of FE5 tracebacks when run on any srpm

Version-Release number of selected component (if applicable):
rpmlint-0.75-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Run rpmlint on any srpm
2. rpmlint tracebacks
3.

Actual results:


Expected results:


Additional info:
For example a the acpid srpm as shipped with FC5:
$ rpmlint acpid-1.0.4-2.src.rpm
W: acpid strange-permission acpid.init 0775
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 248, in ?
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 83, in main
    runChecks(pkg)
  File "/usr/share/rpmlint/rpmlint.py", line 138, in runChecks
    c.check(pkg)
  File "/usr/share/rpmlint/SpecCheck.py", line 88, in check
    spec=file2string(spec_file)
  File "/usr/share/rpmlint/SpecCheck.py", line 60, in file2string
    fd=open(file, "r")
IOError: [Errno 2] No such file or directory:
'/tmp/acpid-1.0.4-2.src.rpm.31590/acpid.spec
Comment 1 Ville Skyttä 2006-03-23 14:29:05 EST
I can't reproduce, so I'm afraid you'll need to try to debug this yourself  
(eg. by adding some print statements here and there and trying to find out  
where exactly things go wrong; a first thing to check would be to see if 
rpm2cpio in Pkg.py succeeds):  
   
$ rpm -q rpmlint   
rpmlint-0.75-1.fc5   
$ rpmlint acpid-1.0.4-2.src.rpm   
W: acpid strange-permission acpid.init 0775   
W: acpid prereq-use /sbin/chkconfig, /sbin/service   
$   
  
Comment 2 Sarantis Paskalis 2006-03-24 03:24:27 EST
Strange, I cannot reproduce it today.

The only hint is from /var/log/yum.log, where the 2 packages updated during the
night were:
Mar 24 05:26:46 Updated: file.i386 4.17-2.fc5
Mar 24 05:26:49 Updated: cpio.i386 2.6-15.FC5

I did install the old versions of them, but could not make rpmlint break again.
 So, I have no idea what it was.

Anyway, thanks and sorry for the noise.
Comment 3 Ville Skyttä 2006-03-24 13:59:50 EST
Broken cpio sounds like a likely culprit; I had already updated it when trying 
to reproduce.  Good to hear that it works for you too now. 

Note You need to log in before you can comment on or make changes to this bug.