Bug 186412 - Anaconda crashes on zero size LVM members
Anaconda crashes on zero size LVM members
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-03-23 08:58 EST by bob mckay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 11:27:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2006-03-23 08:58:03 EST
Description of problem:
If you specify an LVM size of less than one extent (dumb, I know, but us users _are_ dumb), 
anaconda quietly truncates this to zero size, accepts the partitioning, but then crashes (not 
surprisingly) when it tries to creat the partitioning.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select manual partitioning (or review automatic partitioning)
2. Use LVM
3. Create a member of size less than 1 extent
4. Complete installation
  
Actual results:
Anaconda crashes when it tries to create the logical volume

Expected results:
Anaconda warns of zero size LVM members (or better yet, rounds up for sizes less than 1 extent)

Additional info:
Comment 1 Jeremy Katz 2006-03-23 11:24:52 EST
Heh, cute.  I'm somewhat surprised this hasn't been hit before as I'm sure it's
been around since the LVM code was added long ago.

We'll make sure to fix this for FC6, probably just by giving you a "you can't
create a LV < extent size" dialog
Comment 2 bob mckay 2006-03-23 19:47:49 EST
I think this is one of the ways in which the bazaar social model fails in user support. Probably loads of 
people have hit the problem, but been too embarrassed to report it - somehow, reporting your own dumb 
mistake doesn't quite rate with fixing a bug deep in the kernel. Maybe, we need to find a way to celebrate 
us dummies, mcuh as the 'xxx for dummies' series does.
Comment 3 Chris Lumens 2006-05-25 11:27:38 EDT
Implemented Jeremy's suggestion that you not be allowed to create a logical
volume smaller than the extent size in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.