Bug 18642 - emacs-nox requires XFree86 !
Summary: emacs-nox requires XFree86 !
Status: CLOSED DUPLICATE of bug 18548
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-08 14:44 UTC by Alastair Tse
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-08 20:45:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alastair Tse 2000-10-08 14:44:39 UTC
I've just installed RedHat 7.0 onto a box with limited harddisk space. So
I've chosen not to install any XFree86 packages and installed emacs and
emacs-nox packages.

When I try to run emacs it will give me :

"Can't Open Input File : /usr/lib/X11/locale/locale.alias"

and rendering the emacs session useless.

I found in another bug report # that the locale directory exists instead in
/usr/share/locale rather than /usr/lib/X11/locale.

In fact, /usr/lib/X11 is a symlink to /usr/X11R6/lib/X11 which also doesn't
exist because I hadn't installed XFree86-4.0.1 package.

I think someone should look at this to see why emacs-nox requires
XFree86-4.0.1 to functino properly outta the box.

As a temp solution, right now I've created the /usr/X11R6/lib/X11 and put i
a symlink there to link /usr/X11R6/lib/X11/locale to /usr/share/locale.

Comment 1 Trond Eivind Glomsrxd 2000-10-10 20:51:16 UTC

*** This bug has been marked as a duplicate of 18548 ***


Note You need to log in before you can comment on or make changes to this bug.