Bug 186421 - Cannot install / use en_GB dictionary
Cannot install / use en_GB dictionary
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 09:34 EST by Simon Goodall
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 11:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 343901 None None None Never

  None (edit)
Description Simon Goodall 2006-03-23 09:34:15 EST
Description of problem:
I am trying to use the en_GB dictionary downloaded from the mozilla website
through the "get more dictionaries"  link in thunderbird. I have installed it
through the extensions panel and is says it is sucessfully installed, although
it disappears from the list of installed extensions (it does this in windows too).

However, when I try to select the new dictionary, it sill reports only the
english/unitedstates dictionary as the only option. I have tried restarting
thunderbird and re-installing the dictionary, but have had no luck.


Version-Release number of selected component (if applicable):
thunderbird 1.5-6

How reproducible:
always

Steps to Reproduce:
1. download en_GB dictionary from mozilla through the get more dictionaries link.
2. Install .xpi file in the extensions panel.
3. Attempt to change spell checker language
  
Actual results:
Only english/unitedstates dictionary is availalble

Expected results:
expected to see english/great britian in the list of available dictionaries

Additional info:
Comment 1 Bob Peers 2006-03-28 13:16:28 EST
I used to have the same problem but it's the permission. You need to install the
dictionary while running thunderbird as root and then go to your thunderbird
install folder/components/myspell and chmod the contents to 755.
Start thnderbird as a normal user and you now have the dictionary.
Comment 2 Simon Goodall 2006-03-28 13:59:28 EST
Ah, great that worked. So is this thunderbird not setting the correct perms, or
is it the dictionary .xpi?
Comment 3 Bob Peers 2006-03-28 15:52:56 EST
It's because the dictionary is installed into the program folder not the /home
profile folder so requires root access, I believe this is a known thunderbird
dictionary problem and will be changed sometime in the future, but no idea when.
Comment 4 Ian Malone 2006-04-26 07:31:18 EDT
Is it worth having a set of dictionary RPMs like the openoffice.org-langpack ones?

Alternatively since the OpenOffice dictionaries can be used, language packs
which create appropriate symlinks in components/myspell as described by
<http://www.mozilla.com/thunderbird/dictionaries.html> and pull in the
corresponding openoffice.org-langpack as a dependency?
Comment 5 Simon Goodall 2006-05-04 12:25:00 EDT
With the latest thunderbird update (thunderbird-1.5.0.2-1.1.fc5) my dictionary
is broken again. I tried reinstalling it and resetting the permissions and it
does appear in the dictionary list. However *every* word in my email is flagged
as being spelt incorrectly.
This in fact happened with the default dictionary before  I reinstalled the uk one.
Comment 6 Ian Malone 2006-05-06 13:15:46 EDT
Updates typically change the directory name, so now you need the dictionaries
under something like /usr/lib/thunderbird-1.5.0.2/components/myspell, I've just
done the symlink OpenOffice dictionaries thing again as described above.  This
is a pretty good argument for having the dictionaries under the FC package
management system somehow (or, more simply, dictionaries installable under /home)
Comment 7 Thilo Pfennig 2006-09-20 09:26:20 EDT
It all breaks dont to two different possibilites:

a) user the OpenOffice.org myspell
b) install when run application as root.

Both do not present a long term solution.

One suggestion would be to have a location like /usr/lib/mozilla/components that
has no changing name of the parent folder.

The other solution would be that OpenOffice.org and Thunderbird both would use
an extra myspell package as a dependency. I think the latter qwould be the
better solution as then additional applications could use this.

Another thing is the the dictionaries should install into $HOME/thunderbird or
at least Thunderbird should extend its PATH to look there also.

Comment 8 Thilo Pfennig 2006-09-20 09:56:37 EDT
this bug is related.
Comment 9 David W. Legg 2006-09-20 10:27:45 EDT
What I do every time a new thunderbird RPM appears is this:

1. Install the new thunderbird (using yum update.)
2. Find the old version of the dictionaries in /var/.../myspell
3. Cd to the new myspell directory.
4. Create soft links that point to wherever the old version's dictionary files were.

I would have thought that the RPM installer script could do that with a little
bit of ingenuity :)  However, that would mean giving every user the same
dictionaries.

So the idea of simply making thnderbird look in $HOME/.thunderbird for extra
dics seems like the right solution to me (writing merely as a user.)
Comment 10 Christopher Aillon 2006-09-25 11:46:31 EDT
Yeah, thunderbird will look in the profile directory in 2.0 but dictionaries
also need to be updated to install there.  It is a rather major effort that is
ongoing upstream... but unfortunately it means the fix won't make it to fc5. 
It'll be fixed in FC7 for sure, but probably not FC6.

Note You need to log in before you can comment on or make changes to this bug.