Bug 186428 - (fc5floppyhang) Anaconda hangs right after looking for floppy
Anaconda hangs right after looking for floppy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 10:24 EST by Kevin Hobbs
Modified: 2008-03-19 08:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: Fedora 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 12:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Hobbs 2006-03-23 10:24:59 EST
Description of problem:
I've been trying to upgrade from Fedora Core 4 to 5. The install stopps right
after looking for the floppy. I wrote a message to the mailing list with some
details

https://www.redhat.com/archives/fedora-list/2006-March/msg03627.html

The install proceeds as normal until X starts then it just sits there. In text
mode it proceeds untill X would have started then stops.

<Ctrl><Alt><F3> shows me the floppy log message.

Version-Release number of selected component (if applicable):
FC5 anaconda on CD.

How reproducible:
It happens every time on this machine in both graphical and text modes,
askmethod with the images on hard disk and off of the CD.

Steps to Reproduce:
1.boot with CD
2.tell CD bootloader "linux askmethod" or "linux askmethod text" or just ""
3.select keyboard, language
4.select hard drive images if askmethod
5.wait
6.check Console messages and poke around
  
Actual results:
wait for something to ask me if I want to install or upgrade or whatever.

Expected results:
actually being asked if I want to nstall or upgrade or whatever.

Additional info:

I don't think the actuall looking for floppy matters I stuck a floppy in and it
still hung after finding it.
Comment 1 Jeremy Katz 2006-03-23 11:31:17 EST
Can you run commands on tty2 when it hangs?  If so, can you look at top and see
what's going on?
Comment 2 Kevin Hobbs 2006-03-23 11:55:20 EST
I could run commands on tty2. I did run top actually anaconda was top with 99%
CPU usage. I could get more details when I make it home, but other things I
remember are that there were devices in /dev, not a lot but some, and ps said
the mini window manager was running, although there was no sign of it on the
display ( black background big X mouse pointer ). I checked for the devices
because one of the next lines in anaconda after the floppy probe says something
about making them.  I don't know why the mini window manager stuck.

Comment 3 mattyo 2006-03-23 15:05:41 EST
I am having exactly the same issue.  I ran strace on the looping anaconda
process and got this:

Process 552 attached - interrupt to quit
rt_sigaction(SIGSEGV, {0x63dbd0, [], 0}, {0x63dbd0, [], 0}, 8) = 0
sigreturn()                             = ? (mask now [])
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigaction(SIGSEGV, {0x63dbd0, [], 0}, {0x63dbd0, [], 0}, 8) = 0
sigreturn()
--- SIGSEGV (Segmentation fault) @ 0 (0) ---


It repeats forever.  Hardware is Athlon XP on Asus A7N8X mobo (nForce2 chipset)
with ATI 9700pro AGP card.  Machine has run FC 1-4 with no problems.  I also
posted this thread:  http://forums.fedoraforum.org/showthread.php?t=100103 
about it.
Comment 4 pascal kolijn 2006-03-24 04:06:39 EST
I'm also suprised by this one, had no previous install issues with FC1-4, My
Hardware is A7M266-D mobo with 2xAthlon XP, ATI 9600XT AGP card.

Same symptoms: Anaconda using 99% and floppy probe last line on tty3
Comment 5 Kevin Hobbs 2006-03-25 09:37:28 EST
My computer at work was able to get just a little bit furtherbefore it
complained about dmraid. Both my home and work computers have very mixed up (all
arrays are spread across controllers) software raid1. Installing with "linux
nodmraid askmethod" got me passed the errors on both computers.  This error may
be related to dmraid.
Comment 6 Hans Kristian Rosbach 2006-03-25 12:29:29 EST
I have this exact problem. I tried to fix it by disabling floppy drive and
controller in the bios but the message then changed to "no floppy devices found
but we'll try fd0 anyway".

Hardware:
Dell Poweredge 1600SC
Dual 2.8Ghz xeon
256MB ram
ide cdrom
2 ide disks connected to motherboard (one sharing channel with cdrom)
2 ide disks connected to promise fasttrak TX2 card

I can confirm that booting from the cdrom with "linux nodmraid" does indeed fix
this issue. I guess the dmraid code somehow doesn't like my fasttrak card.
The disks are not activated for raid in the promise bios and only contain md
softraid partitions from a previous FC3 install.

I see that the dmraid modules are still loaded into the kernel even though I
specified nodmraid, but luckily it works anyway.
Comment 7 Callum Lerwick 2006-03-25 15:22:56 EST
I'm hitting this problem too. I'm trying to do a fresh networking install using
a rescue disk on a system with an old Tyan dual PII board (440LX chipset) and
onboard aic7xxx SCSI. With a SCSI hard drive and CDROM. The HD only has a single
swap partition on it.

I tried zeroing out the HD entirely, but that didn't help.

nodmraid does fix it.
Comment 8 crapola crapola 2006-03-26 11:01:41 EST
My problem was fixed just as Kevin Hobbs suggested above.  Starting the install
with "linux nodmraid" allowed everything to work fine, even in gui mode.  Thanks.
Comment 9 Trevor Cordes 2006-07-04 08:38:43 EDT
I just hit this bug too.  Upgrading a FC3 box to FC5.  From the sounds of it 
it's a dmraid issue as my system has onboard Promise as well as a few separate 
IDE PCI cards, but I don't use any dmraid features of those controllers (just 
linux kernel software mdraid).
Comment 10 petrosyan 2008-03-10 22:41:30 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 11 Kevin Hobbs 2008-03-11 11:56:04 EDT
I have not encountered this bug again.
Comment 12 Trevor Cordes 2008-03-19 08:55:14 EDT
I haven't seen this issue again either, my box was upgraded fo F8 without problems.

Note You need to log in before you can comment on or make changes to this bug.