Bug 1864280 - [OSP] Machinesets are not generated if there are no availability zones specified
Summary: [OSP] Machinesets are not generated if there are no availability zones specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
: 1862848 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-03 18:41 UTC by Mike Fedosin
Modified: 2020-10-27 16:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:22:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4004 0 None closed Bug 1864280: set AZs default for machine pool in the right place 2021-01-19 15:59:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:57 UTC

Description Mike Fedosin 2020-08-03 18:41:23 UTC
Description of problem:

If I do not specify availability zones in the install config for workers, the installer doesn't generate machinesets at all:
https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_installer/3998/pull-ci-openshift-installer-master-e2e-openstack/1290310675893063680/artifacts/e2e-openstack/machinesets.json

Comment 3 Pierre Prinetti 2020-08-05 10:30:09 UTC
*** Bug 1862848 has been marked as a duplicate of this bug. ***

Comment 4 weiwei jiang 2020-08-06 02:24:27 UTC
Verified.

./openshift-install 4.6.0-0.nightly-2020-08-05-203353
built from commit 4249d9084dc4b1caa5d44e64d392ce1e28545141
release image registry.svc.ci.openshift.org/ocp/release@sha256:4adf81380385ced943687e893896f2612b4b93bb195db23021309689a3ce4592

install-config.yaml:
---
apiVersion: v1
controlPlane:
  architecture: amd64
  hyperthreading: Enabled
  name: master
  platform: {}
  replicas: 3
compute:
- architecture: amd64
  hyperthreading: Enabled
  name: worker
  platform:
    openstack:
      type: m1.large
  replicas: 3
metadata:
  name: wj46ios806a
platform:
  openstack:
    cloud: openstack
    computeFlavor: m1.xlarge
    externalNetwork: provider_net_cci_8
    lbFloatingIP: 10.0.102.70
    ingressFloatingIP: 10.0.100.87
    region: regionOne
    trunkSupport: '1'
    octaviaSupport: '0'
pullSecret: HIDDEN
networking:
  clusterNetwork:
  - cidr: 10.128.0.0/14
    hostPrefix: 23
  serviceNetwork:
  - 172.30.0.0/16
  machineNetwork:
  - cidr: 192.168.0.0/18
  networkType: OpenShiftSDN
publish: External
baseDomain: '0806-s9g.qe.rhcloud.com'
sshKey: ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCWkwurd8TNAi+D7ffvyDdhGBSQtJx3/Yedlwvvha0q772vLlOAGlKCw4dajKy6qty1/GGQDgTJ17h3C9TEArI8ZqILnyydeY56DL+ELN3dtGBVof/N2qtW0+SmEnd1Mi7Qy5Tx4e/GVmB3NgX9szwNOVXhebzgBsXc9x+RtCVLPLC8J+qqSdTUZ0UfJsh2ptlQLGHmmTpF//QlJ1tngvAFeCOxJUhrLAa37P9MtFsiNk31EfKyBk3eIdZljTERmqFaoJCohsFFEdO7tVgU6p5NwniAyBGZVjZBzjELoI1aZ+/g9yReIScxl1R6PWqEzcU6lGo2hInnb6nuZFGb+90D
  openshift-qe@redhat.com


./openshift-install create manifests --dir '/home/jenkins/workspace/Launch Environment Flexy/workdir/install-dir'
level=info msg="Credentials loaded from file \"/home/jenkins/workspace/Launch Environment Flexy/workdir/clouds.yaml.20200806-556-14rdhn6\""
level=info msg="Consuming Install Config from target directory"
level=info msg="Manifests created in: /home/jenkins/workspace/Launch Environment Flexy/workdir/install-dir/manifests and /home/jenkins/workspace/Launch Environment Flexy/workdir/install-dir/openshift"

Comment 6 errata-xmlrpc 2020-10-27 16:22:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.