Bug 186446 - Scribus error with shared libraries
Scribus error with shared libraries
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 11:50 EST by antonio montagnani
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 10:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2006-03-23 11:50:15 EST
Description of problem:
When I start Scribus I get the following message:
Scribus: error while loading shared libraries:libssl.so.5: cannot open shared
object file: No such file or directory

Version-Release number of selected component (if applicable):
Standard Scribus in Fedora Core 5

How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Nothin happens from graphical menu, othyerwise reported warning

Expected results:
start-up of scribus.

Additional info:
Comment 1 antonio montagnani 2006-03-23 12:19:25 EST
sometuhing went wrong during update as I found that there was in plase an fc4
version and not the correct one.I had to disinstall it and re-install, otherwise
updated didn't install the FC5 version.
Comment 2 Gianluca Busco 2006-03-24 10:05:12 EST
Hi,
I've the same problem, see the 186504 bug.

Are you upgrading from FC4?

gianluca
Comment 3 antonio montagnani 2006-03-24 10:10:32 EST
Yes, upgrading from FC4.It seems that Scribus on my PC was one of the  very few
packages (maybe the only package) that were not upgraded correctly.
Comment 4 Gianluca Busco 2006-03-24 10:25:52 EST
(In reply to comment #3)
I've the same problem but I performed a new "scratch" installation. Actually I
can't install some Java applications. But, I tried to solve the trouble with a
simple workaround. So, Are you tried to install a new (extra) application from a
"binary" file?

gianluca
Comment 5 Michael Schwendt 2006-03-24 10:34:00 EST
Can you two please verify that you have Fedora Extras 5 enabled in your
Yum configuration?

> Standard Scribus in Fedora Core 5

That would be scribus-1.2.4.1-4.fc5 which is _not_ linked libssl.so.5
but the newer libssl.so.6. If it didn't, it would have been caught by
the dependency checker we run on Fedora Extras for some time. So, the
Scribus you tried to run is _not_ from Fedora Extras 5, but an older
one.
Comment 6 antonio montagnani 2006-03-24 10:37:58 EST
Michael,

every thing is clear (and solved): I do not understand why Scribus was not
cleanly updated during FC4-to-FC5 upgrade process.And I am not the only one
reporting this bug.
Comment 7 Andreas Bierfert 2006-03-24 18:57:43 EST
Hm I wonder where this comes from:

Newest version on FC4:  scribus-1.2.4.1-3
Newest version on FC5:  scribus-1.2.4.1-4 

So this tells me: FC4 < FC5 and since I took over this was _always_ the case and
I would guess even the case before that.

And doing a rpm --requires scribus clearly shows libssl.so.6 as Michael pointed
out before.
Comment 8 Andreas Bierfert 2006-03-24 19:01:56 EST
well forgot the disttags: should read scribus-1.2.4.1-3.fc4 and
scribus-1.2.4.1-4.fc5

Note You need to log in before you can comment on or make changes to this bug.