This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 186448 - boot process hangs with current init level
boot process hangs with current init level
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On: 186527
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 12:15 EST by Juan A. Burgos
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 09:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juan A. Burgos 2006-03-23 12:15:10 EST
Description of problem:


Version-Release number of selected component (if applicable):

fc5 openldap-servers release version 2.3.19 

How reproducible:

every time the machine boots

Steps to Reproduce:
1. Install fc5 with ldap auth in the same machine as the server runs.
2. boot the machine.
3.
  
Actual results:
the machine hangs looking for the ldap service which is not already up.

Expected results:
the machine continue to boot and presents a login screen.

Additional info:

Modifying the init script to run at S12 alows the machine to boot fine.

During the fistboot auth config the machine hangs to.
Comment 1 Chris Jones 2006-04-05 12:33:22 EDT
I see this as well.
Comment 2 Chris Nguyen 2006-07-06 14:43:58 EDT
I've seen this since I've installed FC5.

Startup looks like its hung, but its waiting for a timeout.  Once the timeout
expires, FC5 boots up fine.

I've been waiting for an openldap update.
Comment 3 Chris Nguyen 2006-09-18 13:22:09 EDT
I have found a solution to the extremely slow startup.

In /etc/ldap.conf, uncomment the following line
# Just assume that there are no supplemental groups for these named users
nss_initgroups_ignoreusers root,ldap

The solution was posted here:
http://www.fedoraforum.org/forum/showthread.php?t=105954
Comment 4 Chris Jones 2006-09-19 10:27:37 EDT
Probably the same bug as [186527]
Comment 5 Jan Safranek 2007-05-22 09:06:50 EDT
please uncomment nss_initgroups_ignoreusers in default /etc/ldap.conf
Comment 6 Juan A. Burgos 2007-05-22 09:22:44 EDT
This issue was solved in fc6 as Jan comment above.

Note You need to log in before you can comment on or make changes to this bug.