Bug 186449 - Categories not complete
Categories not complete
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 12:16 EST by Gérard Milmeister
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 13:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2006-03-23 12:16:55 EST
Not all of the groups from /usr/share/doc/rpm-4.4.2/GROUPS
are considered by Pirut.
For example I cannot find the packages in Development/Languages
anywhere. I can see only Development/Tools.
Comment 1 Jeremy Katz 2006-03-23 13:04:09 EST
The groups shown by pirut aren't the RPM groups, it's the groups from the comps file
Comment 2 Gérard Milmeister 2006-03-23 14:11:22 EST
Does this mean the groups only have packages from Core?
However I see graveman from Extras in Applications/Sound and Video.
But where is pl from Extras (RPM group Development/Languages).
This is quite inconsistent IMHO. Of course there is the list
view, but grouping is easier to browse.
Since I find pirut quite simple and useful otherwise, it would be
nice if grouping applied to all packages.
Comment 3 Jeremy Katz 2006-03-23 14:24:45 EST
There's a comps file per repository.  Extras has a comps file, but it gets
updated by maintainers (note: I need to push the updated file from CVS into the
repos "soon")

And realistically, grouping for all packages isn't what you want.  You want
grouping for _interesting_ packages.  Things like libfoobar aren't generally
useful on their own, but are useful when being used by some application.
Comment 4 Gérard Milmeister 2006-03-23 16:31:10 EST
Well, I understand. Who decides what goes in and what not?
I, as the maintainer of pl (swi-prolog), think that this
is interesting enough to get into Development Tools (like clisp).
Comment 5 Jeremy Katz 2006-03-23 16:48:32 EST
https://www.redhat.com/archives/fedora-extras-list/2006-March/msg00956.html is
the mail I sent on how to add things yourself :)

Note You need to log in before you can comment on or make changes to this bug.