Bug 186458 - openobex: openobex-1.1-inc.patch bogus
Summary: openobex: openobex-1.1-inc.patch bogus
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openobex   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-23 18:07 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-28 09:45:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2006-03-23 18:07:52 UTC
A small thing:

The included openobex-1.1-inc.patch, IMO, is not necessary as well as the bit in
%prep:
sed -i -e 's#includedir=@includedir@#includedir=@includedir@/openobex#g'
openobex.pc.in

Apps using/requiring openobex-devel should
#include <openobex/obex.h>
not
#include <obex.h>
(Else, again IMO, *they* are broken and should be patched... not here in openobex).

Comment 1 David Fraser 2006-05-11 11:59:58 UTC
This could be dealt with in combination with Bug 180935 which would use the same
source rpm for openobex and openobex-apps

Comment 2 Ville Skyttä 2006-06-20 20:10:38 UTC
Bumping severity because the longer this remains the way it currently is, the
more time packagers of dependent apps will spend time working around it.

Comment 3 Harald Hoyer 2006-06-21 08:39:00 UTC
openobex-1.1-inc.patch is necessary, that the include files are installed in
/usr/include/openobex and not in /usr/include directly. I can remove
# sed -i -e 's#includedir=@includedir@#includedir=@includedir@/openobex#g'
BUT, the original openobex packages seems to install the include headers in 
/usr/include without openobex-1.1-inc.patch.

Comment 4 Rex Dieter 2006-06-21 11:22:05 UTC
According to the openobex apidocs:
http://openobex.triq.net/apidocs/c34.html#AEN36
apps using the openobex library are supposed to
#include <openobex/obex.h>
not
#include <obex.h>

Hence, my argument for the bogosity of needing -I/usr/include/openobex

Comment 5 Harald Hoyer 2006-06-21 11:39:24 UTC
Well, then they have to change their Makefile.am, because the way it is now, the
include files are installed in the wrong place.
I will remove the sed line, which corrects the pkgconfig file.

Comment 6 Rex Dieter 2006-06-21 11:50:06 UTC
AFAICT, the include files go to the "wrong place" because you use
%makeinstall
which overrides the Makefile.am value of
includedir = @includedir@/openobex

I'd suggest using in your %install section:
make install DESTDIR=$RPM_BUILD_ROOT
instead.

Comment 7 Rex Dieter 2006-06-21 11:55:29 UTC
While we're at it, a few other small suggestions...

* %{_includedir}/openobex is unowned

* since openobex-devel includes a pkg-config file, it should
Requires: pkgconfig

* You could enable usb support with 
./configure option: --enable-usb
and
BuildRequires: libusb-devel
(not sure if there any consequences of doing so, so that's your call).

Comment 8 Harald Hoyer 2006-06-21 12:48:14 UTC
* %{_includedir}/openobex is unowned

good point

* since openobex-devel includes a pkg-config file, it should
Requires: pkgconfig

You can use openobex-devel without pkgconfig.

* You could enable usb support with 
./configure option: --enable-usb

will do

Comment 9 Harald Hoyer 2006-06-21 13:17:12 UTC
If I would use 
# make install DESTDIR=$RPM_BUILD_ROOT
then the pkgconfig file would include the /usr/include/openobex directory which
would have the same effect like:
# sed -i -e 's#includedir=@includedir@#includedir=@includedir@/openobex#g'

Comment 10 Harald Hoyer 2006-06-21 13:18:12 UTC
hmm, no... forget it... comment #9 is wrong :-)


Note You need to log in before you can comment on or make changes to this bug.