Bug 186477 - tcl should require coreutils for "ln -s" in %post
tcl should require coreutils for "ln -s" in %post
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcl (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 14:49 EST by Brian Long
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 13:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart (4.51 KB, text/plain)
2006-03-24 14:49 EST, Brad Hinson
no flags Details

  None (edit)
Description Brian Long 2006-03-23 14:49:40 EST
Description of problem:
When Anaconda installs tcl, output from %post is included in /root/install.log:
/var/tmp/rpm-tmp.18514: line 5: ln: command not found
error: %post(tcl-8.3.5-92.4) scriptlet failed, exit status 127

Version-Release number of selected component (if applicable):
tcl-8.3.5-92.4

How reproducible:
Always

Steps to Reproduce:
1. Install tcl via kickstart
2. grep -v Install -B1 /root/install.log
  
Actual results:
Error is display

Expected results:
grep should be empty


Additional info:
Add "Requires(post): coreutils" in spec file.
Comment 1 David Cantrell 2006-03-23 15:20:53 EST
This problem affects both the tcl and tk packages in RHEL-3.  Easy fix.  Both
packages get a "Requires(post): coreutils".

Adding to the RHEL-8 U8 Proposed list.
Comment 2 Brian Long 2006-03-23 15:39:49 EST
RHEL 8 seems like a long time to wait for this fix  ;-)
Comment 3 David Cantrell 2006-03-23 15:41:56 EST
You're right.  I meant RHEL-3 U8.
Comment 10 David Cantrell 2006-03-24 14:22:17 EST
Can the customer provide the kickstart file used for this installation?
Comment 11 Brad Hinson 2006-03-24 14:49:15 EST
Created attachment 126662 [details]
kickstart
Comment 12 David Cantrell 2006-03-29 10:18:56 EST
The install.log file shows several scriplet failures due to missing prereqs. 
Most of those look like Cisco packages.  But there are a number of RHEL base
packages that are not installed early on like they should be.

The kickstart file mentions two package groups that don't exist in RHEL: ECS
Desktop and Lab Tools.  If the comps.xml file has been modified, it's possible
an ordering problem was introduced there.
Comment 13 Brian Long 2006-03-29 10:45:15 EST
What I don't understand is why I see coreutils installed before tcl, but tcl
complains "ln" is not found.  This is my only concern at the moment.

Note You need to log in before you can comment on or make changes to this bug.