Bug 186478 - All Fedora Core 5 configuration uses development repositories.
All Fedora Core 5 configuration uses development repositories.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 14:50 EST by Sindre Pedersen Bjørdal
Modified: 2013-01-09 20:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 18:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2006-03-23 14:50:51 EST
Description of problem:

The files in question are:

fedora-5-i386-core.cfg
fedora-5-ppc-core.cfg
fedora-5-x86_64-core.cfg

All these files point to the development repositories, not Core 5 repositories. 

Version-Release number of selected component (if applicable):

mock-0.4-8.fc5
  
Actual results:

Building packages in mock for fedora core 5 on all architectures will pull the
development tree, not Fedora Core 5. 

Expected results:

mock should use the Fedora Core 5 tree for Fedora Core 5 packages.
Comment 1 Orion Poplawski 2006-04-04 13:18:27 EDT
Not sure the symlink think is good - causes problems for me managing the files
with cfengine.

Also, it looks like the plague-results directories have changed from:

[local]
name=local
baseurl=http://extras64.linux.duke.edu/plague-results/development/

to

baseurl=http://extras64.linux.duke.edu/plague-results/fedora-development-extras/
Comment 2 Orion Poplawski 2006-04-04 13:19:14 EDT
Oh, and similar for fedora-{3,4,5}-extras.
Comment 3 Clark Williams 2006-04-18 10:00:14 EDT
Modified all FC5 .cfgs to use '5' repos instead of development (in CVS). Added
devel .cfgs as well.
Comment 4 Brian Pepple 2006-05-10 12:31:37 EDT
Is there any movement on this bug?
Comment 5 Gérard Milmeister 2006-05-16 12:42:27 EDT
(In reply to comment #4)
> Is there any movement on this bug?
I too am waiting for an update. Currently one cannot build in development.
Comment 6 Luya Tshimbalanga 2006-06-06 17:16:01 EDT
I confirmed the problem with mock as well using Fedora Core 5 x86_64:

$ mock rpmbuild/SRPMS/metisse-0.4.0-1.src.rpm 
init
clean
prep
This may take a while
Error peforming yum command: /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-x86_64-core/root groupinstall build
ending
done
Comment 7 Jesse Keating 2006-06-20 18:36:46 EDT
New mock built that uses the Fedora mirror-list to find the repo.  This has the
correct format.

Note You need to log in before you can comment on or make changes to this bug.