Bug 186485 - package redhat-release is not installed, up2date fails
package redhat-release is not installed, up2date fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 15:08 EST by Christopher Cprek
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:45:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Cprek 2006-03-23 15:08:40 EST
Description of problem:
up2date has apparently scrambled the RPM DB on a live critical system. I believe
this might have been the result of a full /boot drive during an up2date
procedure. Regardless, up2date will not run. It complains 

"Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

                rpm --rebuilddb"

'rpm --rebuilddb' does not resolve anything.

Further investigation shows:

[root@ns1 root]# cat /etc/redhat-release
Red Hat Enterprise Linux ES release 3 (Taroon Update 6)

but

[root@ns1 root]# rpm -q redhat-release
package redhat-release is not installed

I'm not sure you to resolve this issue at this point.

Version-Release number of selected component (if applicable):
rpm-4.2.3-24_nonptl
up2date-4.4.67-3

How reproducible:
Always reproducible in current state

Steps to Reproduce:
1. 'up2date -l'
2. fail
3. sob?
  
Actual results:
Failure to use up2date to maintain updates on Redhat purchased subscription channel.

Expected results:
Fully utilize paid subscription fee to update critical packages.

Additional info:
A bug in up2date and/or rpm allowed this system to get in a very troubled state.
Any recommendation on how to repair this system without reinstalling a very
critical box is appreciated.
Comment 1 Christopher Cprek 2006-03-23 15:10:08 EST
up2date logs:

[Mon Mar 20 10:50:48 2006] up2date updating login info
[Mon Mar 20 10:50:48 2006] up2date logging into up2date server
[Mon Mar 20 10:50:49 2006] up2date successfully retrieved authentication token
from up2date server
[Mon Mar 20 10:50:49 2006] up2date availablePackageList from network
[Mon Mar 20 10:50:49 2006] up2date Unable to import repomd support so repomd
support will not be available
[Mon Mar 20 10:51:37 2006] up2date updating login info
[Mon Mar 20 10:51:37 2006] up2date logging into up2date server
[Mon Mar 20 10:51:38 2006] up2date successfully retrieved authentication token
from up2date server
[Mon Mar 20 10:51:38 2006] up2date availablePackageList from network
[Mon Mar 20 10:51:38 2006] up2date Unable to import repomd support so repomd
support will not be available
[Mon Mar 20 10:51:52 2006] up2date installing packages: ['up2date-4.4.67-3']
[Mon Mar 20 10:52:01 2006] up2date Removing packages from package profile:
['up2date-4.4.44-3']
[Mon Mar 20 10:52:03 2006] up2date Adding packages to package profile:
['up2date-4.4.67-3']
[Mon Mar 20 10:52:04 2006] up2date deleting
/var/spool/up2date/up2date-4.4.67-3.i386.hdr
[Mon Mar 20 10:52:04 2006] up2date deleting
/var/spool/up2date/up2date-4.4.67-3.i386.rpm
[Mon Mar 20 10:52:05 2006] up2date updating login info
[Mon Mar 20 10:52:05 2006] up2date logging into up2date server
[Mon Mar 20 10:52:05 2006] up2date successfully retrieved authentication token
from up2date server
[Mon Mar 20 10:52:05 2006] up2date availablePackageList from network
[Mon Mar 20 10:52:05 2006] up2date Unable to import repomd support so repomd
support will not be available
[Mon Mar 20 10:53:22 2006] up2date A protocol error occurred: Not Found ,
attempt #1,
[Mon Mar 20 10:55:33 2006] up2date installing packages:
['XFree86-Mesa-libGL-4.3.0-98.EL', 'XFree86-Mesa-libGLU-4.3.0-98.EL',
'XFree86-libs-4.3.0-98.EL', 'XFree86-libs-data-4.3.0-98.EL', 'autofs-4.1.3-168',
'bash-2.05b-41.5', 'binutils-2.14.90.0.4-42', 'chkconfig-1.3.13.3-0.3',
'comps-3ES-0.20060306', 'cpp-3.2.3-54', 'findutils-4.1.7-9.1', 'gcc-3.2.3-54',
'gcc-c++-3.2.3-54', 'gdb-6.3.0.0-1.90', 'glibc-2.3.2-95.39',
'glibc-common-2.3.2-95.39', 'glibc-devel-2.3.2-95.39',
'glibc-headers-2.3.2-95.39', 'glibc-profile-2.3.2-95.39', 'gnupg-1.2.1-15',
'hwdata-0.101.22-1', 'initscripts-7.31.30.EL-1', 'iputils-20020927-11.30.4',
'kernel-2.4.21-40.EL', 'kernel-pcmcia-cs-3.1.31-19', 'kernel-utils-2.4-8.37.14',
'krb5-devel-1.2.7-52', 'krb5-libs-1.2.7-52', 'krb5-workstation-1.2.7-52',
'libaio-0.3.96-6', 'libaio-devel-0.3.96-6', 'libgcc-3.2.3-54',
'libgcj-3.2.3-54', 'libobjc-3.2.3-54', 'libstdc++-3.2.3-54',
'libstdc++-devel-3.2.3-54', 'man-1.5k-13.rhel3', 'nedit-5.3-4.1',
'netdump-0.7.14-3', 'nfs-utils-1.0.6-43EL', 'nptl-devel-2.3.2-95.39',
'nscd-2.3.2-95.39', 'ntsysv-1.3.13.3-0.3', 'openldap-2.0.27-22',
'openldap-devel-2.0.27-22', 'pam-0.75-67', 'pam-devel-0.75-67',
'psacct-6.3.2-35.rhel3', 'redhat-release-3ES-13.7.3', 'rhnlib-1.8.2-1.p22.1',
'rpmdb-redhat-3-0.20060306', 'shadow-utils-4.0.3-26.RHEL3',
'sysreport-1.3.7.2-13', 'tzdata-2006a-1.EL3', 'vixie-cron-4.1-10.EL3',
'ypbind-1.12-5.21.9']
[Mon Mar 20 12:14:45 2006] up2date updating login info
[Mon Mar 20 12:14:45 2006] up2date RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

                rpm --rebuilddb


[Mon Mar 20 12:15:57 2006] up2date updating login info
[Mon Mar 20 12:15:57 2006] up2date RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

                rpm --rebuilddb


[Mon Mar 20 14:16:26 2006] up2date RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

                rpm --rebuilddb


Comment 2 Paul Nasrat 2006-03-23 15:14:36 EST
Bugzilla is not an avenue for technical assistance or support, but simply a bug
tracking system. 

If you are a Red Hat Enterprise Linux customer and have an active support
entitlement, please log in to Red Hat Support for assistance with your issue, to
ensure your issue is correctly prioritised.

https://www.redhat.com/apps/support/
Comment 3 Christopher Cprek 2006-03-23 15:28:11 EST
I'm already submitting that to support. It just seemed that the bug that caused
this issue needed to be reported as well. Thanks for the quick response. 
Comment 4 Jeff Johnson 2006-03-23 15:29:10 EST
Reinstall redhat-release manually using rpm should "unofficially" fix yer problem.
Comment 5 Paul Nasrat 2006-03-23 15:32:45 EST
Christopher, if you ensure support know this bz number they can link the issue.
Comment 6 Christopher Cprek 2006-03-23 15:45:11 EST
Thanks. Forcing an rpm install from the /var/spool/up2date directory resolved
the redhat-release package problem. I was able to up2date from there. A new full
up2date blew up lots of config files that were similarly unresolved when the
problem occured. I'll have to wade through those for errors, but it looks like
it'll be OK. Support has this BZ number for reference. Thanks again.
Comment 7 Paul Nasrat 2006-06-30 09:53:14 EDT
Reassign to up2date - there should be some way to recover with redhat-release
missing.  Also I think we shouldn't recommend rebuilddb in this instance but
maybe contacting support.
Comment 8 Bret McMillan 2006-06-30 10:08:42 EDT
up2date depends upon the version flag of the redhat-release pkg from the rpm
db... we don't munge the contents of the /etc/redhat-release file. 
redhat-release is the primary mechanism by which we understand what content a
user should be pointed at server-side.

You have the ability to override this using the' versionOverride' config
directive, but reviewing the code, I don't believe this will help Chrisopher, as
it still requires one match against the rpmdb.

I could alter the logic to allowe 'versionOverride' to work w/out any
redhat-release package, but it sure seems like we're focusing on the tail end of
the problem, instead of understanding why the rpmdb got corrupted in the first
place.

Christopher, can you provide any information around that event?
Comment 9 Red Hat Bugzilla 2007-04-11 20:35:19 EDT
User bnackash@redhat.com's account has been closed
Comment 10 RHEL Product and Program Management 2007-10-19 14:45:49 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.