Bug 186500 - FAT32 partitions triggers py-exception during install
FAT32 partitions triggers py-exception during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 16:45 EST by Dov Grobgeld
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 16:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (163.90 KB, text/plain)
2006-03-28 15:06 EST, Eric Walstad
no flags Details

  None (edit)
Description Dov Grobgeld 2006-03-23 16:45:54 EST
Trying to upgrade my FC4 to a FC5 system crashed during installation. Through
the python debugger I traced it down to the mount function in fsset.py, line
1036. The problem is that I have a FAT32 partition that I use as a transfer area
between Linux and Windows. This partition was considered mountable in the
isMountable() function. But the function getFStoTry() returned an empty list.
(Is it because of the patent issue with the FAT32 systems?) Since there were no
fs to try to mount the function fell throw to the exception. The exception is
also problematic as it references errNum which hasn't been assigned yet. So I
guess that you should decide whether FAT32 partitions are mountable or not.

Meanwhile I will change the partition type of the FAT32 partition to something
obscure that hopefully will be deemed unmountable. And once I have upgraded the
system I will change it back.
Comment 1 Dov Grobgeld 2006-03-24 01:29:58 EST
I just wanted to mention that the workaround that I suggested above works just
fine. I.e. I entered fdisk, changed the partition type of the problematic
partition with the t command to "eb" (beos fs), installed FC5 during the night.
Now I just changed back the partition type to "b", and remounted the partition.

Btw. Thanks a lot for the option of attaching to the Python debugger when the
installation failed! Without it I wouldn't be running FC5 now.

Comment 2 Jeremy Katz 2006-03-27 13:06:57 EST
Can you provide the complete traceback you received?
Comment 3 Dov Grobgeld 2006-03-27 14:15:16 EST
Sorry. I didn't record it. The info I gave is all I have. Would you like me to
try to run the installation on the same computer again and store the traceback
if the errors reoccurs?
Comment 4 Eric Walstad 2006-03-28 15:01:39 EST
I received the same python traceback today when attempting to upgrade my IBM
Thinkpad A31 from Fedora Core 4 to Fedora Core 5:

  File "/usr/lib/anaconda/fsset.py", line 1050, in mount
    raise SystemError (errNum, errMsg)
UnboundLocalError: local variable 'errNum' referenced before assignment

Mine is a dual-boot system with Windows 2000 on hda1 and FC4 on hda2.

I'll attach my anacdump.txt file to this bug in a minute...

Thanks,

Eric.
Comment 5 Eric Walstad 2006-03-28 15:06:06 EST
Created attachment 126926 [details]
Anaconda dump
Comment 6 Chris Lumens 2006-03-28 16:20:04 EST
This is because you have a line in your /etc/fstab for an NTFS filesystem (or
other filesystem we don't support) that is listed as type auto.  If you change
the filesystem type on that line to whatever it really is, your upgrade should
get past this point.  I've added a more useful error message in Rawhide and
we'll work on making sure we don't try to mount these filesystems in the future.
Comment 7 Eric Walstad 2006-03-28 17:18:23 EST
Yes, my fstab had a line to mount my hda1, fat32, partition.

I didn't try changing type 'auto' to 'fat32'.  I commented out that line and now
the installation (still in progress) appears to be proceeding nicely.

Note You need to log in before you can comment on or make changes to this bug.