Bug 186503 - KDE adding printer in Pinters Control Center fails as normal user
KDE adding printer in Pinters Control Center fails as normal user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 17:15 EST by Gabriel Ramirez
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 19:49:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Ramirez 2006-03-23 17:15:30 EST
Description of problem:

I tried to add a cups printer as normal user in KDE Printers Control Center at a
 stage ask for a accunt and password , I tried with my account and root's
account and the password fails with:

/var/log/messages cupsd[10539]: pam_ldap: error trying to bind as user "uid=roo
t,ou=People,dc=daflabs,dc=mty,dc=itesm,dc=mx" (Invalid credentials)

/var/log/cups/error.log E [23/Mar/2006:15:27:59 -0600] IsAuthorized:
pam_authenticate() returned 7 (Authentication failure)! 

I tried disabling selinux with the same results.

I push the Administratr mode button asked a account , I tried with root's
account  and I successfully add a cups printer


Version-Release number of selected component (if applicable):

kdelibs-3.5.1-0.1.fc4 and latest updates to selinux and cups applied today

How reproducible:

always

Steps to Reproduce:
1. as normal user log into kde
2. open KDE Printers Control Center
3. try to add a Printer
3.  when asked for a account ( the dialog don't specify if need the rot account)
give the root account and password
4. the system is unable to autenticate it

  
Actual results:

unable to add a printer folllowing the workflow of the wizard

Expected results:

install a printer with the wizard


Additional info:
Comment 1 Ngo Than 2006-07-14 19:49:28 EDT
there's new KDE-3.5.3 in FC4-update, you should please update to new KDE 
version. Please reopen if the bug still appears. Thanks

Note You need to log in before you can comment on or make changes to this bug.