Bug 18651 - XFree86 4.01 crashes when switched to a virtual terminal
XFree86 4.01 crashes when switched to a virtual terminal
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-10-08 14:57 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-09 01:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-08 14:57:04 EDT
I'm running XFree86 v4.01 (rh 7.0).  After hopping out of X into a virtual
terminal (using alt-ctrl-FunctionKey) X will usually crash within a few
minutes.  It will die with a standard segfault error and then a bunch of
GTK messages angry because X has gone away.

I'm running a stock Rh7.0 install with gnome.  My box is a dual PIII-450
with a VooDoo III PCI card.  I've tried using the expirimental dri driver
with the same results.  X seems to run fine if I don't switch to a VT.

please let me know if you need any more info.  I couldn't find a core file
from XFree86, but if you need one just let me know what to do.

Comment 1 Mike A. Harris 2001-04-09 01:57:04 EDT
What video mode and color depth are you using, and do you have DRI enabled?
Attach your X server logs and config file using the link below.

If you are using DRI, you must use 16bpp color depth as other color depths
are not supported I don't believe.  You might also want to give the latest
Rawhide version a shot.  XFree86-4.0.3-5
Comment 2 Mike A. Harris 2001-05-10 22:32:33 EDT
Fixed in 4.0.3-14 in rawhide

Note You need to log in before you can comment on or make changes to this bug.