Bug 18651 - XFree86 4.01 crashes when switched to a virtual terminal
Summary: XFree86 4.01 crashes when switched to a virtual terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-08 18:57 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-09 05:57:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-08 18:57:04 UTC
I'm running XFree86 v4.01 (rh 7.0).  After hopping out of X into a virtual
terminal (using alt-ctrl-FunctionKey) X will usually crash within a few
minutes.  It will die with a standard segfault error and then a bunch of
GTK messages angry because X has gone away.

I'm running a stock Rh7.0 install with gnome.  My box is a dual PIII-450
with a VooDoo III PCI card.  I've tried using the expirimental dri driver
with the same results.  X seems to run fine if I don't switch to a VT.

please let me know if you need any more info.  I couldn't find a core file
from XFree86, but if you need one just let me know what to do.

Thanks.

Comment 1 Mike A. Harris 2001-04-09 05:57:04 UTC
What video mode and color depth are you using, and do you have DRI enabled?
Attach your X server logs and config file using the link below.

If you are using DRI, you must use 16bpp color depth as other color depths
are not supported I don't believe.  You might also want to give the latest
Rawhide version a shot.  XFree86-4.0.3-5

Comment 2 Mike A. Harris 2001-05-11 02:32:33 UTC
Fixed in 4.0.3-14 in rawhide


Note You need to log in before you can comment on or make changes to this bug.