Bug 186516 - Completely unable to print
Completely unable to print
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 19:16 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-02 19:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printer configuration file (569 bytes, text/plain)
2006-03-30 14:30 EST, Paul F. Johnson
no flags Details
error log from CUPS test from comment 19 (8.85 KB, application/octet-stream)
2006-04-01 03:08 EST, Anton Guda
no flags Details

  None (edit)
Description Paul F. Johnson 2006-03-23 19:16:00 EST
Description of problem:
CUPS seems to be having big problems! I've tried to set up my printers through
the conventional s-c-p route and all seems to be fine, except that when I try to
do a test print, nothing comes out.

To see what was going on, I went through the web interface. No printers had been
defined. I defined my USB inkjet (HP 980cxi) and my laser printer (/dev/lp0 -
Samsung ML2250) and tried to do a test print. The message back was that /dev/lp0
permissiond denied and ""Filter "rastertoprinter" for printer
"HP_DeskJet_980C_USB_1" not available: No such file or directory"" for the HP.

Version-Release number of se
lected component (if applicable):
cups-1.2-0.1.b2.2
foomatic-3.0.2-33.2

How reproducible:
Always

Steps to Reproduce:
1. Define a printer using s-c-p
2. Define a printer using the web interface
3.
  
Actual results:
Under s-c-p, the printers appear to be defined and nothing happens with a test
print.

Under web interface, nothing was defined using s-c-p. If you add printers, no
output is given

Expected results:
The printers should work

Additional info:
I have selinux switched off to ensure that is not the problem
Comment 1 Anton Guda 2006-03-24 08:27:13 EST
It seems, that libraries from and and new cups binary incompatible, 
but soversion is the same. I failed to rebuild kdelibs with new cups. 
IMHO such great changes must be documented  
(and marked by '!!!') in changelog. 
 
 
 
Comment 2 Anton Guda 2006-03-24 08:27:40 EST
It seems, that libraries from and and new cups binary incompatible, 
but soversion is the same. I failed to rebuild kdelibs with new cups. 
IMHO such great changes must be documented  
(and marked by '!!!') in changelog. 
 
 
 
Comment 3 Tim Waugh 2006-03-24 08:31:15 EST
Anton: please file this as a separate bug.  It is very important, so I want it
to be tracked appropriately.  Thanks.
Comment 4 Tim Waugh 2006-03-27 13:00:54 EST
Paul: upgrade to foomatic-3.0.2-34.
Comment 5 Paul F. Johnson 2006-03-27 17:09:14 EST
I'm on 3.0.2-34 and still cannot print.

I've defined my printers using s-c-p and when asked, said yes to printing a test
file. scp returned the following error

There was a problem sending CUPS test page
to 'ML2250' queue:

/usr/bin/lpr: The printer or class was not found.

(the printer is on /dev/lp0)
Comment 6 Paul F. Johnson 2006-03-27 17:10:35 EST
Downgrading to the version of CUPS in the stable release doesn't fix this
problem, so the problem seems to be between foomatic and CUPS.
Comment 7 Tim Waugh 2006-03-28 03:03:15 EST
Please

1. upgrade to cups-1.2-0.2.rc1.1 from today's rawhide, and
2. run '/usr/sbin/printconf-backend --force-rebuild' as root
   or, alternatively, make some trivial change in s-c-printer and click Apply.

Can you print now?
Comment 8 Paul F. Johnson 2006-03-28 13:53:51 EST
Done the upgrade, ran /usr/sbin/printconf-backend --force-rebuild, tried to
print, nothing.

Ran s-c-p, removed and added my current printers (Samsung ML2250, /dev/lp0 and
HP-DJ980cxi on USB) again. Tried to test print.

s-c-p came back with 

There was a problem sending CUPS test page
to 'ML2250' queue:

/usr/bin/lpr: The printer or class was not found.
Comment 9 Paul F. Johnson 2006-03-28 13:56:04 EST
I've checked, I don't have SELinux running and have no firewall running. I've
tried to restart the CUPS server (worked fine) and then print, gave the same
error as in #8
Comment 10 Paul F. Johnson 2006-03-29 19:01:21 EST
cups-1.2-0.2.rc1.2 now doesn't give the lpr error, but still doesn't print. I've
wiped the old config and set up a new one and still zilch.
Comment 11 Tim Waugh 2006-03-30 05:17:45 EST
Please try these packages:

ftp://people.redhat.com/twaugh/tmp/cups-devel/

Comment 12 Paul F. Johnson 2006-03-30 10:21:59 EST
Nope. Gave the /usr/bin/lpr error again. I'll try it at home later. What's the
xinetd dep. for on these rpms?
Comment 13 Tim Waugh 2006-03-30 11:11:10 EST
(xinetd is required only for cups-lpd)

1. Please show me the output of this command: lpstat -s
2. Please attach /etc/cups/printers.conf

Thanks.
Comment 14 Paul F. Johnson 2006-03-30 14:26:02 EST
lpstat -s
system default destination: ML2250
device for DJ980cxi: usb:/dev/usb/lp0
device for ML2250: parallel:/dev/lp0

/etc/cups/printers.conf attached
Comment 15 Paul F. Johnson 2006-03-30 14:30:17 EST
Created attachment 127067 [details]
printer configuration file

As requested.
Comment 16 Tim Waugh 2006-03-31 10:24:07 EST
Does this work?:

lp -dML2250 /usr/share/cups/data/testprint.ps

Or in general, does printing work from other apps than system-config-printer?
Comment 17 Paul F. Johnson 2006-03-31 10:30:00 EST
I've issued the lp -dML2250 command remotely, so will know in an hour or so if
it's worked (I'm at work currently).

Printing is not working from any application at all.
Comment 18 Paul F. Johnson 2006-03-31 12:40:39 EST
File didn't print.
Comment 19 Anton Guda 2006-04-01 03:06:56 EST
More test: 
 
0. exist 1 physical printer (HP6L) on /dev/lp0 and 3 logical: {lp0 lp1 gimp} 
   with drivers {ljet4, hpijs, gimp-print-ijs} 
1. installed cups-1.2-0.2.rc1.3 (local rebuild) 
2. run actions from POSTIN:foomatic-3.0.2-34 
3. run s-c-p, try to print test page from all logical printers: 
   no printout, but LED on printer flashes. 
4. try lpr -P... test.ps : same result. 
5. http://127.0.0.1:631, printers: 
   see: printer with gimp-print-ijs dirver not functional, 
   all other ok 
   print test page on lp0 -- OK 
6. log attached 
    
Comment 20 Anton Guda 2006-04-01 03:08:21 EST
Created attachment 127170 [details]
error log from CUPS test from comment 19
Comment 21 Paul F. Johnson 2006-04-02 07:28:41 EDT
rc1.4 seems to have fixed the problem. Next one, why is the USB printer not
working, but I'll file the apart. If Anton doesn't have a problem, I'll close
this bug later today
Comment 22 Anton Guda 2006-04-04 02:29:08 EDT
Tested cups-1.2-0.2.rc1.5.
It seems, that pstops filter add bad (null) bytes to postscript.
And LANG env. var. set incorrectly.
Will be reported as soon as investigated.

Note You need to log in before you can comment on or make changes to this bug.