Bug 186520 - CONFIG_PCI_MSI is not set to y in installed x86_64 2.6.15 kernel for fc5
CONFIG_PCI_MSI is not set to y in installed x86_64 2.6.15 kernel for fc5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 19:50 EST by Dave Olson
Modified: 2015-01-04 17:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-15 21:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Olson 2006-03-23 19:50:50 EST
As installed, the .config does not have MSI enabled.   It was
enabled for FC4 and FC3 kernels.  I can't find any reason in
the release notes or lkml for it being disabled.

Our PathScale InfiniPath product requires MSI in order to function,
and I was surprised to find that I had to install the kernel source
rpm and reconfigure in order for MSI to function.

Was this a deliberate change, and if so, what was the reason?
Comment 1 Dave Jones 2006-03-24 17:42:47 EST
It caused problems booting on some systems.  I don't have the details to hand.
Comment 2 Bryan O'Sullivan 2006-03-27 18:16:15 EST
This is a big problem for us.
Comment 3 Greg Lindahl 2006-03-31 15:52:23 EST
1. Our cards are the first of probably many which require MSI. MSI was optional
for PCI-X but is required for PCI Express.

2. Other cards like the Mellanox InfiniBand adaptor run faster with MSI enabled
-- see the OpenIB mailing list for discussion about this a while ago.

I have no doubt that some systems have problems with MSI, but they're broken and
will probably get fixed, for example I spent 2 days arguing with the in-house
BIOS team at a Tier 1 computer vendor (a big Red Hat partner) and they finally
agreed that they needed to fix their BIOS so that MSI worked. It turned out to
be a one-line fix...
Comment 4 Dave Olson 2006-04-03 13:38:43 EDT
It appears that the latest FC 4 2.6.16 kernel now has the same issue, that
is, the default 2.6.16 kernel with FC4 yum update now has CONFIG_PCI_MSI=n
Comment 5 Dave Olson 2006-05-09 01:58:25 EDT
It appears that the latest fc4 update kernels (e.g. 2.6.16-1.2108_FC4smp for
x86_64) now has CONFIG_PSI_MSI=y again, and I'm told FC5 has also reverted
to enabling this.   Should we expect that to remain true for future 
Fedora kernels?
Comment 6 Dave Jones 2006-05-09 19:59:35 EDT
no (it was on as an experiment in fc4, and sneaked into an update
inadvertantly), I'm going to look at enabling it across the board when I rebase
to 2.6.17

Note You need to log in before you can comment on or make changes to this bug.