Bug 1865212 - pew: FTBFS in Fedora rawhide/f33+, FailsToInstall on F35+
Summary: pew: FTBFS in Fedora rawhide/f33+, FailsToInstall on F35+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pew
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Tadej Janež
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1968856 (view as bug list)
Depends On:
Blocks: F34FTBFS F35FTBFS F35FailsToInstall F36FTBFS F33FTBFS PYTHON3.10 F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-08-03 20:41 UTC by Fedora Release Engineering
Modified: 2021-10-06 15:57 UTC (History)
7 users (show)

Fixed In Version: pew-1.2.0-13.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-06 15:57:17 UTC
Type: ---


Attachments (Terms of Use)
build.log (24.16 KB, text/plain)
2020-08-03 20:41 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2020-08-03 20:41 UTC, Fedora Release Engineering
no flags Details
state.log (939 bytes, text/plain)
2020-08-03 20:41 UTC, Fedora Release Engineering
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github berdario pew issues 218 0 None open Future of Pew? 2020-11-30 23:35:42 UTC
Github berdario pew issues 219 0 None open Support virtualenv 20+ 2020-11-30 23:35:42 UTC

Description Fedora Release Engineering 2020-08-03 20:41:00 UTC
pew failed to build from source in Fedora rawhide/f33

https://koji.fedoraproject.org/koji/taskinfo?taskID=48349391


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
Please fix pew at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
pew will be orphaned. Before branching of Fedora 34,
pew will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-08-03 20:41:02 UTC
Created attachment 1708819 [details]
build.log

Comment 2 Fedora Release Engineering 2020-08-03 20:41:03 UTC
Created attachment 1708820 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-08-03 20:41:04 UTC
Created attachment 1708821 [details]
state.log

Comment 4 Tadej Janež 2020-08-05 19:51:47 UTC
I've filled an upstream bug report about issues with virtualenv 20+: https://github.com/berdario/pew/issues/219.

Since there hasn't been any activity for more than a year, I've also queried upstream about their plans for the future: https://github.com/berdario/pew/issues/218.

Comment 5 Ben Cotton 2020-08-11 15:03:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 6 Miro Hrončok 2021-06-04 20:14:52 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 7 Miro Hrončok 2021-06-07 22:59:25 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 8 Miro Hrončok 2021-06-08 11:19:25 UTC
*** Bug 1968856 has been marked as a duplicate of this bug. ***

Comment 9 Miro Hrončok 2021-08-23 11:41:04 UTC
(In reply to Tadej Janež from comment #4)
> I've filled an upstream bug report about issues with virtualenv 20+:
> https://github.com/berdario/pew/issues/219.
> 
> Since there hasn't been any activity for more than a year, I've also queried
> upstream about their plans for the future:
> https://github.com/berdario/pew/issues/218.

Tadej, now would be a good time to consider what is our path forward. The package does not even install On Fedora 35+ and upstream has not migrated away from the old virtualenv yet. 

Should pew bundle virtualenv 16? Or should we temporarily remove it from Fedora until this is resolved?

Comment 10 Tadej Janež 2021-08-26 11:50:17 UTC
(In reply to Miro Hrončok from comment #9)
> 
> Tadej, now would be a good time to consider what is our path forward. The
> package does not even install On Fedora 35+ and upstream has not migrated
> away from the old virtualenv yet. 
> 
> Should pew bundle virtualenv 16? Or should we temporarily remove it from
> Fedora until this is resolved?

Miro, I've taken a shot at trying to revive Pew by testing it on recent Python versions and supporting virtualenv 20+:
https://github.com/berdario/pew/pull/214

Comment 11 Miro Hrončok 2021-09-13 09:18:24 UTC
What is the plan wrt https://github.com/berdario/pew/pull/214 ? Should we backport this in Fedora to test it out in Rawhide and F35? The beta release is near.

Comment 12 Tadej Janež 2021-09-14 12:42:49 UTC
(In reply to Miro Hrončok from comment #11)
> What is the plan wrt https://github.com/berdario/pew/pull/214 ?

I plan to wrap it up in the next few days.

> Should we backport this in Fedora to test it out in Rawhide and F35? The beta release
> is near.

Yes, I plan to backport it and make Pew usable on F35.

Comment 13 Miro Hrončok 2021-09-29 14:44:16 UTC
The final freeze for F35 starts in less than a week on Tuesday 2021-10-05. Setting severity to urgent.

Comment 14 Fedora Update System 2021-10-01 11:12:18 UTC
FEDORA-2021-050b1fba64 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-050b1fba64

Comment 15 Miro Hrončok 2021-10-01 11:16:25 UTC
Requesting a freeze exception, as the update might not make it to stable before the freeze starts.

The package does not even install without the fix. I'd like to avoid noninstallable packages in GA repos.

Comment 16 Tadej Janež 2021-10-01 11:22:44 UTC
(In reply to Miro Hrončok from comment #15)
> Requesting a freeze exception, as the update might not make it to stable
> before the freeze starts.

Thanks, Miro!

> The package does not even install without the fix. I'd like to avoid
> noninstallable packages in GA repos.

Agreed.

Comment 17 Fedora Update System 2021-10-02 02:22:50 UTC
FEDORA-2021-050b1fba64 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-050b1fba64`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-050b1fba64

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Miro Hrončok 2021-10-04 15:50:19 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 19 Adam Williamson 2021-10-06 00:18:40 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/489 , marking accepted.

Comment 20 Fedora Update System 2021-10-06 15:57:17 UTC
FEDORA-2021-050b1fba64 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.