Bug 1865274 - python-beanbag: FTBFS in Fedora rawhide/f33
Summary: python-beanbag: FTBFS in Fedora rawhide/f33
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-beanbag
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1891796 (view as bug list)
Depends On:
Blocks: F33FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-08-03 20:48 UTC by Fedora Release Engineering
Modified: 2020-10-29 17:01 UTC (History)
4 users (show)

Fixed In Version: python-beanbag-1.9.2-20.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-29 16:13:39 UTC
Type: ---


Attachments (Terms of Use)
build.log (11.26 KB, text/plain)
2020-08-03 20:48 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2020-08-03 20:48 UTC, Fedora Release Engineering
no flags Details
state.log (1011 bytes, text/plain)
2020-08-03 20:48 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-08-03 20:48:48 UTC
python-beanbag failed to build from source in Fedora rawhide/f33

https://koji.fedoraproject.org/koji/taskinfo?taskID=48350311


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
Please fix python-beanbag at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-beanbag will be orphaned. Before branching of Fedora 34,
python-beanbag will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-08-03 20:48:50 UTC
Created attachment 1709001 [details]
build.log

Comment 2 Fedora Release Engineering 2020-08-03 20:48:51 UTC
Created attachment 1709002 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-08-03 20:48:52 UTC
Created attachment 1709003 [details]
state.log

Comment 4 Ben Cotton 2020-08-11 15:05:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 5 Fedora Release Engineering 2020-09-30 19:00:35 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 33.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2020-09-28).

A week before the mass branching of Fedora 34 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 32 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html

Comment 6 Fedora Release Engineering 2020-10-04 04:37:13 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 33.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2020-09-28).

A week before the mass branching of Fedora 34 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 32 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html

Comment 7 Fedora Admin user for bugzilla script actions 2020-10-09 14:53:28 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 8 Fedora Release Engineering 2020-10-25 04:37:53 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 33.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2020-09-28).

A week before the mass branching of Fedora 34 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 32 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html

Comment 9 Miro Hrončok 2020-10-26 17:13:12 UTC
The build issue is:

ERROR: test_attrdict.test_manipulation
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/beanbag-1.9.2/tests/test_attrdict.py", line 19, in test_manipulation
    py.test.raises(KeyError, "str(ad.c.x.y.z)")
  File "/usr/lib/python3.9/site-packages/_pytest/python_api.py", line 699, in raises
    raise TypeError(
TypeError: 'str(ad.c.x.y.z)' object (type: <class 'str'>) must be callable


This is a pytest compatibility thing. Instead of:

     py.test.raises(KeyError, "str(ad.c.x.y.z)")

It should be:

    with pytest.raises(KeyError):
        str(ad.c.x.y.z)


Similarly later with py.test.raises(KeyError, "del ad.bar.baz").

Comment 10 Miro Hrončok 2020-10-27 12:13:52 UTC
*** Bug 1891796 has been marked as a duplicate of this bug. ***

Comment 11 Miro Hrončok 2020-10-29 16:13:39 UTC
Fixed the test failure in rawhide. Since it does not change anything on runtime, I have decided not to backport. Feel free to do so if you disagree.

Comment 12 Fedora Update System 2020-10-29 17:01:59 UTC
FEDORA-2020-bf15fa22da has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.