Bug 1865308 - [Baremetal] Post-upgrade to 4.6, new added worker node will run Keepalived mode != rest of nodes.
Summary: [Baremetal] Post-upgrade to 4.6, new added worker node will run Keepalived mo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yossi Boaron
QA Contact: Nataf Sharabi
URL:
Whiteboard:
Depends On: 1872742 1875237
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-03 20:55 UTC by Yossi Boaron
Modified: 2020-10-27 16:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:23:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:23:27 UTC

Description Yossi Boaron 2020-08-03 20:55:15 UTC
Reproduce steps:

1. Run upgrade from 4.5 to 4.6
Keepalived will continue to tun in multicast mode
2. Add a new worker node

Actual results:
The new node run Keepalived in unicast mode 

Expected results:

The new node should run Keepalived in the same mode as rest of the nodes

Comment 2 Yossi Boaron 2020-08-05 11:12:22 UTC
The fix for this bug was already merged, see [1] 

[1] https://github.com/openshift/machine-config-operator/pull/1968

Comment 5 Nataf Sharabi 2020-10-16 07:13:16 UTC
Verified on:

oc version
Client Version: 4.6.0-0.nightly-2020-10-03-051134
Server Version: 4.5.13
Kubernetes Version: v1.18.3+47c0e71

Worked by procedure [1] to verify.

After adding the worker-0-2,

cat /etc/keepalived/keepalived.con:

.
.
.
unicast_src_ip 192.168.123.149                                                                                                                                                            
    unicast_peer {                                                                                                                                                                            
                                                                                                                                                                                              
        192.168.123.128
         
        192.168.123.119
         
        192.168.123.109
         
        192.168.123.133
         
        192.168.123.135       
         
    }

.
.
.

[1]https://polarion.engineering.redhat.com/polarion/#/project/OSE/workitem?id=OCP-29807

Comment 7 errata-xmlrpc 2020-10-27 16:23:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.