Bug 186536 - firefox really really needs a way to use esd
firefox really really needs a way to use esd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 00:54 EST by Joshua Jensen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 11:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2006-03-24 00:54:16 EST
Description of problem:

firefox in FC5 seems not to use esd, though the firefox rpms *do require* the
esound package.  firefox, when run by itself or even with "esddsp firefox",
won't use esd.  If nothing else is bound to /dev/dsp*, then it will grab it and
use it, but I'm not aware of a way to make it use esd

Gaim and xmms and gnome are all sharing sound output nicely with esd.. but
firefox is missing out!

Version-Release number of selected component (if applicable):

firefox in FC5
Comment 1 Doncho N. Gunchev 2006-04-06 07:22:54 EDT
Firefox should not use ESD. What about KDE users in this case, ARTS? This, and 
many other problems, can be solved with ALSA's software mixing capabilities. 
As far as I remember the idea was to use some universal sound server. 
Comment 2 Joshua Jensen 2006-04-10 17:05:11 EDT
esd does not preclude KDE users.  If you would like to ask for native arts
support from firefox, please feel free to open a bugzilla reqruest.  Currently
Firefox uses OSS, which the kernel constantly reminds me of:

application firefox-bin uses obsolete OSS audio interface

The first thing to do would be to make firefox use ALSA.  Actually, it should
have a sound output option that allows plugins, somewhat like xmms does.  ALSA
would be a choice, OSS would still be available, esd/esound, and ARTS support as
well.
Comment 3 James Cornell 2006-04-25 15:17:56 EDT
Just use Alsa Dmix.  It's more compatible, it works.  OSS if the Firefox GNOME people have any clue about 
portability to other POSIX operating systems running GNOME.  Maybe default to alsa, have OSS support for 
2.4 systems, BSD, and Solaris.
Comment 4 Joshua Jensen 2006-08-03 15:13:15 EDT
Yes.... I'll agree with this (comment #13)
Comment 5 Joshua Jensen 2006-10-28 21:56:23 EDT
Lets just make Firefox or Firefox2 alsa-aware.
Comment 6 Warren Togami 2006-10-29 08:24:46 EST
Are you sure this is even firefox's fault?

Is firefox itself using OSS output or the browser plugins like Flash?  I am
pretty sure it is the latter.
Comment 7 Christopher Aillon 2006-10-29 11:33:20 EST
Firefox has been using esd since forever. 
http://lxr.mozilla.org/mozilla/source/widget/src/gtk2/nsSound.cpp

Of note, filling bugs detailing implementation details are silly.  If something
isn't working, file a bug that ABC isn't working.

This bug as filed, doesn't exist.
Comment 8 Warren Togami 2006-10-29 14:27:32 EST
Then I highly suspect this is NOTABUG?

Note You need to log in before you can comment on or make changes to this bug.