Bug 186543 - glx without dri causes crash
glx without dri causes crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 04:13 EST by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 12:54:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2006-03-24 04:13:26 EST
Description of problem:

When starting the X server with glx, but without dri, you get:

X: symbol lookup error: /usr/lib/xorg/modules/extensions/libglx.so: undefined
symbol: DRIQueryDirectRenderingCapable
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

This bug wasn't present in the previous version (1.0.1-something). Avoiding to
load DRI is desirable since it eats half of the available video memory.


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.0.99.1-1


How reproducible:

Every time


Steps to Reproduce:
1. Make sure Load "glx" is in the conf, but not Load "dri".
2. Try to start X server.

  
Actual results:

X server crashes.


Expected results:

Everything runs with GLX extension, but without direct rendering support.
Comment 1 Kristian Høgsberg 2006-03-24 12:54:47 EST
Ah, good point, this is fixed in cvs head now.  We'll pick it up when we build a
new snapshot.  For now, add

        Option         "AIGLX" "0"

to your serverlayout section in xorg.conf to avoid the crash.


Note You need to log in before you can comment on or make changes to this bug.