Bug 186564 - ACPI 2.0 systems with no XSDT fail to boot
ACPI 2.0 systems with no XSDT fail to boot
Status: CLOSED DUPLICATE of bug 165809
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Konrad Rzeszutek
Brian Brock
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-03-24 09:01 EST by Konrad Rzeszutek
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 09:48:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Back-port from 2.6.12 to 2.6.9 (3.71 KB, patch)
2006-03-24 09:04 EST, Konrad Rzeszutek
no flags Details | Diff

  None (edit)
Description Konrad Rzeszutek 2006-03-24 09:01:11 EST
Description of problem:

The ACPI routines make a blunt assumption that if a system is ACPI 2.0
compliant an XSDT table will be present.  This does not appear to be a
requirement of the ACPI 2.0 spec.  However, the spec does not outline how to
properly signify that no XSDT table is present.  If a BIOS leaves the XSDT
pointer field in the RSDP NULL'd or set to any other value to indicate that it
is invalid the ACPI routine will try to use this as the address of the XSDT.  
Upon failure of validating the XSDT, the ACPI system will not fall back and use
the RSDT pointer.

Version-Release number of selected component (if applicable):

RHEL4 U1

How reproducible:

Any machine that has ACPI v2.0 without XSDT table.

Steps to Reproduce:
1. Boot Linux
  
Actual results:
Hang

Expected results:
Not hang

Additional info:

The patch for this had been submitted to the ACPI maintaners. The patch 
had been submitted as ACPI CA release. git-commit:
http://marc.theaimsgroup.com/?l=git-commits-head&m=112619202228915&w=2
Comment 1 Konrad Rzeszutek 2006-03-24 09:04:12 EST
Created attachment 126625 [details]
Back-port from 2.6.12 to 2.6.9

Patch applies cleanly to RHEL4 U3.
Comment 2 Konrad Rzeszutek 2006-03-24 09:10:21 EST
Patch posted for review.
Comment 3 Konrad Rzeszutek 2006-03-29 09:48:57 EST

*** This bug has been marked as a duplicate of 165809 ***

Note You need to log in before you can comment on or make changes to this bug.