Bug 186568 - rdesktop crash bug (X_CreateColormap)
rdesktop crash bug (X_CreateColormap)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 09:36 EST by Jörgen Busink
Modified: 2013-03-05 22:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jörgen Busink 2006-03-24 09:36:21 EST
Description of problem: rdesktop crashes with the following error:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  78 (X_CreateColormap)
  Value in failed request:  0x0
  Serial number of failed request:  7
  Current serial number in output stream:  8


Version-Release number of selected component (if applicable): rdesktop-1.4.1-3.2.1

How reproducible:
Just run rdesktop (or call through tsclient). eg: rdesktop 10.31.1.13. Using -C
flag doesn't change a thing.


Additional info:

This is a clean install of FC5. Tried as unprivileged user as well as root.
Comment 1 Mike McGrath 2006-04-03 10:06:50 EDT
j. Busink: just curious, is your machine a dual head?
Comment 2 Jörgen Busink 2006-04-03 10:15:08 EDT
Yes it it.
Comment 3 Mike McGrath 2006-04-03 10:22:41 EDT
I'm getting this same issue with rdesktop and qemu (dual-head).  I've seen
others that have the same issue but I have no idea whats causing it.  I'm
running the binary nvidia drivers, I'm going to do some testing and see if I can
figure out whats going on.
Comment 4 Jörgen Busink 2006-04-03 10:35:58 EDT
switching to twinview instead of xinerama fixed it for me.

this issue is related to the binary nvidia drivers. after some testing I noticed
the same (or similar) error messages when running other programs as well (most
notably glxgears). Thus this has nothing to do with rdesktop at all. I recommend
closing this bug.
Comment 5 Mike McGrath 2006-04-03 11:00:39 EDT
I'm seeing the same behavior.
Comment 6 Jonathan Trull 2006-05-22 16:11:30 EDT
I had this problem on RHEL4 using the Nvidia binary drivers and TwinView.  I
noticed that it started right at the same time I used up2date to update to
xorg-x11-6.8.2-1.EL.13.25.1 and friends.  I reinstalled the same version of the
Nvidia driver (I'm using AMD64/EM64T version 1.0-8756) and the error went away.
Comment 7 Mike McGrath 2006-05-23 17:00:18 EDT
Some new drivers are out, I haven't had time to test them though...

http://www.nvidia.com/object/unix.html
Comment 8 Robert 'Bob' Jensen 2006-11-23 04:44:34 EST
Fedora Version: FC6 Clean install
rdesktop version: 0:1.4.1-4
nvidia driver: xorg-x11-drv-nvidia-legacy-1.0.7184-2.lvn6

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  78 (X_CreateColormap)
  Value in failed request:  0x290
  Serial number of failed request:  7
  Current serial number in output stream:  8

Running a quad head so twinview is not an option nor is the open source driver.
I never saw this bug in FC5. 
Comment 9 petrosyan 2008-03-11 00:43:07 EDT
Fedora Core 6 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 10 Bug Zapper 2008-04-03 22:14:25 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Bug Zapper 2008-05-06 11:37:48 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.