Bug 1865828 - "Edit Pod Count" modal is not closed automatically after clicking "Save"
Summary: "Edit Pod Count" modal is not closed automatically after clicking "Save"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1866839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-04 09:52 UTC by Yanping Zhang
Modified: 2020-10-27 16:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:23:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6204 0 None closed Bug 1865828: Components with withHandlePromise wrapper should be called accordingly 2020-10-28 10:43:31 UTC
Github openshift console pull 6276 0 None closed Bug 1865828: User 'close' method from the props 2020-10-28 10:43:31 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:23:29 UTC

Description Yanping Zhang 2020-08-04 09:52:59 UTC
Description of problem:
Edit pod count of deployment/dc from action list, after clicking "Save", the modal is not closed automatically, user has to click "Cancel" to close the modal

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-03-143208

How reproducible:
Always

Steps to Reproduce:
1.Create a deployment or dc in project.
2.Edit pod count of deployment/dc from action list, then click "Save"
3.

Actual results:
2.The modal is always open after clicking "Save".

Expected results:
2. Should close the modal automatically after clicking "Save".

Additional info:

Comment 1 Yanping Zhang 2020-08-04 10:29:26 UTC
Same issue exists for "Edit Annotations" from action list/kebab list

Comment 2 Samuel Padgett 2020-08-04 14:11:50 UTC
This was probably introduced by https://github.com/openshift/console/pull/6048. We might need to check every dialog.

cc Gilad

Comment 5 Yadan Pei 2020-08-07 01:29:11 UTC
*** Bug 1866839 has been marked as a duplicate of this bug. ***

Comment 6 Yanping Zhang 2020-08-10 06:58:53 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.nightly-2020-08-07-100201.
Now "Edit Pod Count" modal could close normally. "Edit Machine Count" modal could close normally.
But "Edit Annotations" modal still has the issue, will it be fixed in this bug? Assign the bug first, if need fix annotations modal in new bug, pls feel free to change the bug status.

Comment 8 XiaochuanWang 2020-08-11 02:20:04 UTC
Edit Pod Count/Edit Annotations/Edit Labels can all close the overlay editor normally.
Verified on 4.6.0-0.nightly-2020-08-10-200500

Comment 10 errata-xmlrpc 2020-10-27 16:23:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.