Bug 186583 - sendmail-8.13.6-1.src.rpm build fails on old systems
Summary: sendmail-8.13.6-1.src.rpm build fails on old systems
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-24 15:55 UTC by Sami Pitko
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 14:43:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sami Pitko 2006-03-24 15:55:08 UTC
Description of problem:

sendmail-8.13.6-1.src.rpm does not compile on Red Hat 9, Fedora Core 1 nor Red 
Hat Enterprise Linux 3

sendmail.spec has been modified following:

%define       with_sasl1    yes
%define       with_sasl2    no
%define       enable_pie    no
%define       old_setup     yes

Above changes enables building with sendmail-8.13.3-1.src.rpm

Build stops with following error message:

Making in /usr/src/redhat/BUILD/sendmail-8.13.6/obj.Linux.2.4.22-
1.2199.nptl.i686/libmilter
cc `-O2 -g -march=i386 -mcpu=i686' -I. -I../../sendmail   -I../../include  -
I/usr/include/db4 -I/usr/kerberos/include -Wall -DXDEBUG=0 -DTCPWRAPPERS -
DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1 -
D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SSL -DSASL=1 -
D_FFR_UNSAFE_SASL -DSM_CONF_LDAP_MEMFREE=1 -DNOT_SENDMAIL -
Dsm_snprintf=snprintf -D_FFR_MILTER_ROOT_UNSAFE -D_REENTRANT -DXP_MT   -c -o 
main.o main.c
/bin/sh: -c: line 1: unexpected EOF while looking for matching ``'
/bin/sh: -c: line 2: syntax error: unexpected end of file
make: *** [main.o] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.93020 (%build)


Version-Release number of selected component (if applicable):

8.13.3-1 works
8.13.5 and forward doesn't work

How reproducible:

Reproduced in Red Hat 9, Fedora Core 1 and Red Hat Enterprise Linux 3.

Steps to Reproduce:
1. download and install src.rpm
2. modify sendmail.spec
3. rpmbuild -ba sendmail.spec
  
Actual results:


Expected results:


Additional info:

Comment 1 Sami Pitko 2006-03-24 20:21:23 UTC
Resolution found. Change sendmail.spec confOPTIMIZE value back to pre 8.13.3-
1.1 setting:

define(\`confOPTIMIZE', \`${RPM_OPT_FLAGS}')

Resolution verified with Fedora Core 1 and Red Hat Enterprise Linux 3.
Change of confOPTIMIZE value does not affect Fedora Core 4 ability to build 
sendmail-8.13.6-1.src.rpm

sendmail.spec changelog has following entry:

* Tue Mar  1 2005 Thomas Woerner <twoerner@redhat.com> 8.13.3-1.1
- fixed gcc4 build: use double quotes for confOPTIMIZE to avoid m4 confusion
  with ','

That fix apparently broke the srpm for systems using gcc3.

Comment 2 Robert Scheck 2006-07-09 17:00:24 UTC
Red Hat Linux 9 and Fedora Core < 4 are deprecated since longer time now and 
shouldn't be used anywhere except with Fedora Legacy. What you're trying to
do is heavily unsupported. And Red Hat Enterprise Linux was never and will
never be a playground system for such obvious backports. Therefore suggesting
to close with WONTFIX/DEFERRED.


Note You need to log in before you can comment on or make changes to this bug.