Bug 1866033 - All content selected when visiting YAML tab
Summary: All content selected when visiting YAML tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-04 17:15 UTC by Samuel Padgett
Modified: 2020-10-27 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-02-134243 Cluster ID: 6de0fe23-5d9b-4add-a336-1efc5fad0306 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:80.0) Gecko/20100101 Firefox/80.0
Last Closed: 2020-10-27 16:23:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6239 0 None closed Bug 1866033: Use Monaco APIs to set YAML editor value 2020-08-11 02:04:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:23:33 UTC

Description Samuel Padgett 2020-08-04 17:15:55 UTC
This seems to happen when viewing YAML for an existing resource or creating a new resource from YAML. The entire content is preselected when you visit the tab. We shouldn't be preselecting the content. It makes it harder to read and makes it easy to accidentally delete.

This might be a regression from bumping the monaco dependencies in https://github.com/openshift/console/pull/6157

Comment 1 ralpert 2020-08-05 20:01:27 UTC
I don't see anything obvious; I reached out to Josh Pinkney to see if he has any ideas here.

Comment 2 Samuel Padgett 2020-08-05 21:23:03 UTC
Hi, Rebecca. I happened to start looking at this when I opened the bug, and I have a fix.

Comment 5 XiaochuanWang 2020-08-11 02:06:10 UTC
This is not reproduced.
Verified on 4.6.0-0.nightly-2020-08-10-200500

Comment 7 errata-xmlrpc 2020-10-27 16:23:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.