Bug 1866048 - bond configured but not visible on machine console
Summary: bond configured but not visible on machine console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.5
Hardware: x86_64
OS: All
low
low
Target Milestone: ---
: 4.6.0
Assignee: Kelvin Fan
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1186913
TreeView+ depends on / blocked
 
Reported: 2020-08-04 18:08 UTC by Jatan Malde
Modified: 2020-10-27 16:23 UTC (History)
7 users (show)

Fixed In Version: 4.6
Doc Type: Bug Fix
Doc Text:
Cause: Udev rules that trigger the generation of network interface information snippets are too strict. Consequence: Udev rules do not pick up on certain network interfaces being added (e.g. bonds), and thus certain network interfaces do not have their information displayed on the console. Fix: Use NetworkManager dispatcher scripts instead of udev rules and make rules more permissive. Result: The information of network interfaces that have permanent hardware addresses or are backed by a devices that have permanent hardware addresses are shown on the console at log in.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:23:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github coreos console-login-helper-messages pull 67 0 None closed gensnippet: Support displaying complex n/w dev info 2020-10-15 18:18:03 UTC
Red Hat Knowledge Base (Solution) 5295041 0 None None None 2020-08-04 20:36:38 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:23:33 UTC

Description Jatan Malde 2020-08-04 18:08:02 UTC
Description of problem:

  If a rhcos node is configured with multiple nic along with bond configuration. It is expected to see the bond on the rhcos node when you open the machine console. 

     https://github.com/coreos/console-login-helper-messages/issues/34

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Setup the a rhcos node with multiple nic and bond on the kernel cmd line
2. Finally once the node is up, check the console to see if you are able to see the bond configured or not. 
3.

Actual results:

Currently bond is not visible on the console.

Expected results:
The node works perfectly fine and the bond is working too, only issue seen is with machine console. 

Additional info:

Comment 1 Dusty Mabe 2020-08-04 20:29:52 UTC
+1. Yes this does look like https://github.com/coreos/console-login-helper-messages/issues/34. Do we all agree it's a cosmetic issue? We should fix it but it's not a blocker for anything if I understand correctly.

Comment 2 Micah Abbott 2020-08-04 20:47:48 UTC
Looks like a match to me; keeping Low priority and targeting for 4.6

Comment 5 Dusty Mabe 2020-09-28 17:46:01 UTC
I verified this morning that booting with rhcos-46.82.202009260308-0-qemu.x86_64.qcow2 showed the ip address for bond0 on the console:

```
[  OK  ] Started Update UTMP about System Runlevel Changes.

Red Hat Enterprise Linux CoreOS 46.82.202009260308-0 (Ootpa) 4.6
SSH host key: SHA256:LiyrBvwt9f7d0XL1HNW/N//Ba46HliBT59afNPxCBUU (ECDSA)
SSH host key: SHA256:si7fw5e7hDC1WoldYJgoZxE4TuvmTlQOtaceSPG+eBI (ED25519)
SSH host key: SHA256:H23cm/K0agW/9OlSxnqcfECeHlNZ5/jLshYubO0MbsU (RSA)
bond0: 192.168.122.111 fe80::5054:ff:fe05:3a6f
ens2:  
ens3:  
initrdhost login:
```

I used kernel arguments:

```
rd.neednet=1 ip=192.168.122.111::192.168.122.1:255.255.255.0:initrdhost:bond0 nameserver=208.67.222.222 bond=bond0:ens2,ens3:mode=active-backup
```

The 46.82.202009260308-0 version has:

```
$ rpm-ostree status
State: idle
Deployments:
* ostree://d3960e7635f10667938c64eddcb64670f9db907f3174fea3c494a7582c2e1322
                   Version: 46.82.202009260308-0 (2020-09-26T03:12:09Z)

$ rpm -qa | grep console-login-helper-messages
console-login-helper-messages-0.19-1.rhaos4.6.el8.noarch
console-login-helper-messages-issuegen-0.19-1.rhaos4.6.el8.noarch
console-login-helper-messages-profile-0.19-1.rhaos4.6.el8.noarch
```

Comment 8 errata-xmlrpc 2020-10-27 16:23:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.