Bug 186609 - Evolution does not read my system mailbox
Evolution does not read my system mailbox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 12:44 EST by Gilles Berger Sabbatel
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 14:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles Berger Sabbatel 2006-03-24 12:44:56 EST
Description of problem:

Evolution does not show my system mailbox on my imap server

Version-Release number of selected component (if applicable):

evolution-2.6.0-1

How reproducible:

Steps to Reproduce:
1. Configure an account on an imap server (details later)
2. Try to read your mail
3.
  
Actual results:

System mailbox is not displayed

Expected results:

System mail box should be displayed

Additional info:

Imap server : Fedora core 4, uw-imap-2004g-3.fc4 from Fedora Extras
Folders stored in ~/Courrier on the server can be read normaly. 

Option "Overrife server supplied namespace" is checked, Namespace is set to
"Courrier".  If the option is unchecked, evolution gets a lot of data from the
server (several minutes at 100Mbit/s), and then use 100% of CPU for a very long
time (I always stopped it before the end...).

The previous version (under Fedora Core 4), or Thunderbird works fine on thise
server.  My mailbox on my home access provider (imap.free.fr) is corretly
accessed through Imap and evolution (UW imap also, AFAIK).
Comment 1 Mark A J Ashdown 2006-03-29 09:07:45 EST
I have encountered the same problem. Previously I had no problem reading the
Inbox on my mail server using IMAP with evolution 2.2.3 in FC4. I updated from
FC4 to FC5 by doing a fresh install while preserving the data in my home
directory. I can still read all the folders in ~/mail on my mail server, but I
can't access the Inbox.

The email account in question is configured with the "Override server supplied
namespace" option checked and with Namespace set to "mail" (which worked
before). Unchecking the override option seems not to change anything.

I tried to solve the problem by configuring evolution from scratch again. I
moved ~/.evolution to another directory and removed (and backed up) all of
evolution's gconf keys. When I tried to set up the email account without
checking the "Override server supplied namespace" option, evolution just sat
there consuming 100% of the processor time but doing nothing else (no network
activity). Eventually I killed it. When I selected the override option, it
behaved as before: I could read the folders in ~/mail, but not the Inbox.
Comment 2 Gustavo Maciel Dias Vieira 2006-03-30 09:31:23 EST
Same problem here. It broke on upgrade from FC4 top FC5. It currently works with
Thunderbird in FC5, so I rule out server misconfiguration.

My situation is similar. In FC4 I had "Show only subscribed folders" checked and
 had not overrided the server namespace (it worked fine since I subscribed to
folders using SquirelMail, can't remeber why, but I remember doing it just
once). When I upgraded to FC5, evolution would just stuck, doing nothing. Then I
tried to restrict the server namespace to mail (witch is stricly correct in my
setup, even though it worked without the override before). This time it worked,
but the INBOX vanished, with a strage message about it already being subscribed.

If anyone need more info, just ask.
Comment 3 Alejandro Gonzalez Hernandez - Imoq 2006-03-31 11:02:05 EST
I can only add a "me too" here, since the situation has already been described.

I had to temporary switch to thunderbird, which seems to work all right, but I
really would like to go back to Evolution sometime soon.

Please let me know if I can provide additional information, but my scenario is
the same than the others.
Comment 4 hdcg 2006-03-31 12:24:10 EST
Me too. Simliar scenario described above, but the IMAP server is RHEL3U7.
Comment 5 Gilles Berger Sabbatel 2006-04-01 06:14:07 EST
There is a temporary workaround, for those who have a shell access to their mail
server : on the server, create a symnlink to your system mailbox
(/var/spool/mail/login_name) in your mail directory.
Comment 6 Phil Hale 2006-04-06 18:01:14 EDT
I'm having the same issue:  FC5 x86_64 evolution 2.6.0-1 connecting to a RHL9
box running uw-imap 2001a-18.2.legacy.  I did manage to use the symlink
workaround to at least view mail.  

If you let the evolution try to process the entire contents of the folder (don't
override the server namespace) you will eventually get subscribed to all the
files in your home folder.  I do see the INBOX when this completes though. 
Depending on how many files you have in your home folder and what they range
from in size, it could take evolution a long time to load.  Once it is loaded
and you try to go and unsubscribe all folders but the ones in "~/mail",
evolution will most likely crash.
Comment 7 Alejandro Gonzalez Hernandez - Imoq 2006-04-17 18:52:06 EDT
Is this bug corrected with evolution-2.6.1-1.fc5.2 released today? I don't have
time to test it yet :(
Comment 8 Gilles Berger Sabbatel 2006-04-20 03:57:02 EDT
No, it is not.
Comment 9 Matěj Cepl 2007-08-31 11:20:37 EDT
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 10 Gustavo Maciel Dias Vieira 2007-08-31 13:18:47 EDT
For me it was fixed with an update to FC5, can't remember exactly when. I has
not reappeared in FC6 or F7.

Note You need to log in before you can comment on or make changes to this bug.