Bug 186613 - yum fails to upgrade wine
yum fails to upgrade wine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 13:23 EST by james
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 13:27:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2006-03-24 13:23:01 EST
Version-Release number of selected component (if applicable):
yum-2.4.1-1.fc4

How reproducible:
always

Steps to Reproduce:
$ rpm -q wine
wine-20050419-1fc3winehq

"wine-0.9.10-1.fc4" is in
 http://fedoraproject.org/extras/4/i386/wine-0.9.10-1.fc4.i386.rpm


$ sudo yum -y update wine
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for wine
No Packages marked for Update/Obsoletion


Additional info:

[extras]
name=Fedora Extras $releasever - $basearch
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-extras-$releasever
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras
gpgcheck=1
Comment 1 Seth Vidal 2006-03-24 13:27:06 EST
why do you think that:
20050419 is a lesser version than 0.9.10?

Yum's not failing to upgrade anything. 0.9.10 is not a version upgrade over
20050419, not by a long shot.
Comment 2 james 2006-03-24 13:46:54 EST
Because I don't know any better!  So then "lesser" and "greater" is strictly
alphanumeric sort order?  That would be nice to see in the documentation.

I erased the old wine, and then yum install wine seems to work fine.

Thanks.
Comment 3 Seth Vidal 2006-03-24 13:49:53 EST
no. it's not strictly alphanumeric sort order and the rpm version comparison
routines  are fairly well documented.

In the case you presented you weren't do anything complicated - just one number
vs another number.

which is higher for you? 0 or 20050419?

Comment 4 james 2006-03-24 14:00:17 EST
> no. it's not strictly alphanumeric sort order and the rpm version comparison
> routines  are fairly well documented.

Perhaps - you don't say _where_ version comparison is documented.

Still, this was an issue with the _yum_ sort order, NOT the _rpm_ sort order. 
Did you mean to suggest that yum uses rpm for version comparison?
Comment 5 Seth Vidal 2006-03-24 14:03:53 EST
1. the version comparison is documented in the rpm devel docs.
2. yum's sort order is using rpmlib and rpm's version comparison routines to do
the comparison.

Comment 6 james 2006-03-24 14:17:27 EST
Ok.  Thanks for that.

Note You need to log in before you can comment on or make changes to this bug.