Bug 18662 - Can't mound file systems - previous major/minor #'s now incorrect
Can't mound file systems - previous major/minor #'s now incorrect
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 19:21 EDT by Roger Penn
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 09:06:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Penn 2000-10-08 19:21:01 EDT
I read the bug about not being able to mount floppys vfat (#18490). The 
suggested solution was to remove all vfat mounts from fstab. Did that, no 
luck. However, my problem is not confined to vfat. I cannot mount a 
floppy, no matter what file system, without the following error:

mount: /dev/hd0 has wrong major or minor number.

The major/minors for a floppy have always been 0/0 as far as I know, and 
worked just fine under 6.2. I upgrade to 7.0 and can no longer access my 
floppy (or windows partitions, but that's less critical). You posted a 
bugfix (anaconda-vfat-label-fix.img) that requires dd'ing an image to a 
floppy and booting with that. How the heck can I dd it to a floppy when I 
can't mount a floppy?!? Yes, I could do it on another working system, but 
that's not the point. What if I didn't have access to one?

Here's the bizarre part- I do not have this problem on my "desktop" 
system. I upgraded to 7.0 and the same old fstab entry mounts floppys just 
fine. This problem only occurs on my IBM ThinkPad 600X. Had no problem 
under 6.2, but now I can't use a floppy with 7.0. I am going to try to 
make and use that fix img, and see what happens. But I would still 
consider this a "bug" regardless. Whether or not it has any priority, of 
course, depends on whether or not it's confined to ThinkPad 600X's or 
affects lots of people.
Comment 1 Bernhard Rosenkraenzer 2000-10-09 05:29:40 EDT
I can't reproduce this (but then I don't have a thinkpad). Is the thinkpad doing
any oddities in floppy access (PCMCIA or USB floppy?)?
Comment 2 Roger Penn 2000-10-09 06:56:21 EDT
No, it's neither a USB or PCMCIA floppy, it's the OEM floppy connected to the 
floppy port. And no, it's not doing anything strange. It's always worked fine. 
I was able to format an ext2 floppy on my other machine and it mounted fine on 
the Thinkpad. So I saved my essential configuration files to floppy (which is 
why I needed it so) and then did a clean workstation install. The new install 
(with an identical fstab, I might add) works just fine. In fact I was very 
impressed that compared to installing 6.2 on the same laptop and all the hoop-
jumping and workarounds that had to be done, this was a snap and everything 
works great (except the sound card - never could make that work). So the 
problem appears to be only a result of an upgrade from 6.2. I don't think this 
one's worth the time and effort to fix on the off chance that someone, 
somewhere, might also do a default upgrade from 6.2 to 7.0 on a Thinkpad 600X 
and have this problem. Unless you do...
Comment 3 Need Real Name 2000-10-16 16:45:29 EDT
I have the problem mounting windows partitions that this user alluded to.  I get the same error about wrong major or minor number.  I am using an AST 
desktop system with an AMD 586 processor running at 133 Mhz.  The drives are set up like this

hda - Windows drive with a linux swap partition
hdb - CDRom drive
hdc - Linux drive

The swap partition works OK as far as I can tell.
Comment 4 Need Real Name 2000-10-27 12:37:05 EDT
I too am havin the same problem when I try to mount my cdrom on my HP Omnibook 
XE2 laptop - 'major or minor number incorrect'.
Comment 5 Need Real Name 2000-10-27 15:03:33 EDT
I figured out my problem.  When I created a boot disk I had the write protect on so I was booting my 7.0 system with a 6.1 vmlinuz.  I recreated the boot 
disk and then everything worked OK.
Comment 6 Need Real Name 2000-10-30 09:06:46 EST
Judging by Jsusanj's response above, I think it may be due to the upgrade path 
- I noticed that I am booting with my old kernel, when I try a lilo -v I get a 
'geo_comp_addr:Cylinder number is too big' (1108 > 1023) error.
Comment 7 Bernhard Rosenkraenzer 2000-11-03 05:00:30 EST
Can't work with old kernels because of internal changes.

Note You need to log in before you can comment on or make changes to this bug.