Bug 186624 - Segfault after responding to Password Manager dialog
Segfault after responding to Password Manager dialog
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rssowl (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 15:08 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 16:36:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2006-03-24 15:08:27 EST
Description of problem:
rssowl segfaults if you try to log in to a site in the internal browser, after
you click No in the Password Manager dialog.

I think the problem is that SWT has not been updated to be compatible with the
version of mozilla shipped in FC5.

Version-Release number of selected component (if applicable):
rssowl-1.2-11.fc5

How reproducible:
Always

Steps to Reproduce:
1. Help -> Homepage
2. Fill in anything in the username and password boxes
3. Click login
4. Click No in the password manager dialog
  
Actual results:
Crash

Expected results:
No crash
Comment 1 Robin Green 2006-03-25 12:19:22 EST
(In reply to comment #0)
> I think the problem is that SWT has not been updated to be compatible with the
> version of mozilla shipped in FC5.

Or maybe not. I installed the mozilla, mozilla-nss and mozilla-nspr RPMs from
Fedora Core 4, and restarted rssowl, but I still got the crash. But according to 
http://www.eclipse.org/swt/faq.php#browserlinux
mozilla 1.7.8 (which is the version I installed) is supposed to be supported.
Comment 2 Anthony Green 2006-04-02 13:40:51 EDT
I can't reproduce this on 32-bit x86.  I'll try x86-64 later today.
Comment 3 Anthony Green 2007-11-11 16:36:45 EST
RSSOwl is no longer part of Fedora due to licensing concerns.  I'm going to
WONTFIX this one.

Note You need to log in before you can comment on or make changes to this bug.